when I run the ethtool command on eth0 ( on VM machine redhat version 6.7 )

I see Supports auto-negotiation: No

can we change this to - auto-negotiation: yes ? , is it configurable?

 ethtool eth0
 Settings for eth0:
       Supported ports: [ TP ]
       Supported link modes:   1000baseT/Full
       Supported pause frame use: No
       Supports auto-negotiation: No
       Advertised link modes:  Not reported
       Advertised pause frame use: No
       Advertised auto-negotiation: No
       Speed: 10000Mb/s
       Duplex: Full
       Port: Twisted Pair
       PHYAD: 0
       Transceiver: internal
       Auto-negotiation: off
       MDI-X: Unknown
       Supports Wake-on: uag
       Wake-on: d
       Link detected: yes
  • Pretty certain 10Gb Ethernet does not support auto-negotiation. It is always full duplex,
    – fpmurphy
    Mar 30, 2016 at 12:29

1 Answer 1




files can have the ethtool settings added to them so that the settings are saved and used every time the device is activated.

Config file option

ETHTOOL_OPTS="speed <100|1000|10000> duplex <half|full> autoneg <on|off>"

Add this line at the end of your configuration file :

ETHTOOL_OPTS="speed 1000 duplex full autoneg on"


/etc/init.d/network restart

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .