2

This server was recently shut down due to power cut. When I tried booting up, BSOD appeared with an error stating : process1_initialization_failed. According to MS this was a result of corrupted boot record. I have tried recovering the record so far by:

  1. Deleting bootrec.cache (did not work)
  2. bootrec /fixmbr (did not work)
  3. Autorepair and sfc (Sfc refused to work)

Currently the situation is worse as boot goes into system restore but no drive is detected.

P.S This is a Hyper-V virtual machine running domain controller (and other important stuff) The hosting machine works without any problems.

HELLLLLLLLLLP

4
  • update: i have restarted the hyper v server and now the disks are recognizing, but the error is still the same. help. – Someone 1 Mar 30 '16 at 12:49
  • Might be better to add to your question yesterday than to keep making new questions. serverfault.com/questions/766735/… – Nixphoe Mar 30 '16 at 13:28
  • When you say you have deleted: Bootrec.cache do you mean: Bootcat.cache? – Adam Chetnik Mar 30 '16 at 20:00
  • @AdamChetnik Yes. – Someone 1 Mar 31 '16 at 8:12
1

The VM could have been waiting for a restart following installation of some Windows Updates. Have a look for the

pending.xml

see here: Link

You might find a few problem DLLs are causing your issue.

5
  • Hmm. I have actually managed to delete pending.xml and try running sfc, which at some point claims that files (d:\windows\winsxs\ for example) are corrupted. – Someone 1 Mar 31 '16 at 8:38
  • I am able now to boot up into repair mode (not via CD, at least yet) into command prompt, which gives me: Drive X: (temp os?) and then drive d, e,f, which are the normal partitions (and would be normally c,d,e). I can go into folders but it wouldn't list files stating they are corrupted. – Someone 1 Mar 31 '16 at 8:39
  • chkdsk states that the file system is now raw and it cannot scan raw, but diskpart lists the partitions as ntfs and healthy. The weird thing is that booting as normal does bring an OS (the windows icon animation, options to boot as normal or go into repair mode), If the disk was all corrupted, the errors I would get would be no system disk. – Someone 1 Mar 31 '16 at 8:41
  • Lastly, the process1 error according to what I've found so far is a boot sector or manager error that might cause the rest, and on some forums it says not to ignore the raw file system errors, not format and correct the boot issue, which so far I haven't been able to do :/ – Someone 1 Mar 31 '16 at 8:42
  • If you can get into repair mode, try running: startup repair, link: mikemstech.blogspot.co.uk/2012/01/troubleshooting-0x6b.html – Adam Chetnik Mar 31 '16 at 9:18
0

Solved. Here's what I've done:

  1. Made a copy of the VHD file, just in case things get messier.
  2. Created a new VM and attached the VHD file as an additional drive.
  3. Started the machine. This verified that the virtual hard drive is in fact not damaged or raw. All files were there
  4. Ran SFC /scannnow /offwindir=drive:\windows /offwindir=drive (drive is the letter for the additional drive)
  5. Copied ntdll.dll from the new machine running Windows Server 2008 R2 to both system32 and syswow64 folders. Had to take ownership on the folders for that and then change ownership back.
  6. Restarted the old VM with the amended drive. Machine ran chkdsk first, and booted as normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.