2

I'm struggling getting Group Policy Preferences Drive Mapping to work over wireless (WPA2-Enterprise using Certificates) from our Windows 10 Surface Pro 4s. The Active Directory user account's Home Folder drive map also does not appear. All of these paths use DFS (Server 2008 R2).

Shortly after login, a manual Gpupdate will cause the mapped drives to appear. Waiting 30 seconds before login also works.

We've had the "Always wait for the network at computer startup and logon" enabled since XP days. I tried setting the "Specify startup policy processing wait time" to 60 but this made no difference (nor did it lengthen boot). The wireless NIC does not appear to have a "Wait For Link" type setting to enable.

Event logs show Event ID 4098 with source "Group Policy Drive Maps" saying the preference item "failed with error code '0x80070035 The network path was not found.'"

I had wondered if the underlying problem might be the new UNC Hardening feature but even adding an exception for "\\DomainNetBIOSname" did not help. (See here: Windows 10: Group Policy fails to apply directly after boot, succeeds later)

The only significant clue to what's going on is that when I changed my user account home folder to a direct UNC path to the server rather than via DFS, my home drive was able to appear correctly. The DFS Client service (as seen in regedit) already has a Start type signifying "System".

I'm not sure where to go from here. Does anyone have any ideas? Thanks!

  • Do you have the group policy set against the user, group or computer? – Citizen Mar 30 '16 at 16:52
  • It's User policy preferences that do the drive mapping based on group membership. "Wait for network" is a Computer policy. – Cantoris Mar 30 '16 at 17:01
  • Have you tried the 'wait for network' using a User Policy? – Citizen Mar 30 '16 at 17:15
  • That setting only exists in the Computer side of policy. – Cantoris Mar 31 '16 at 8:26
  • Apologies if I sent you down a dead end and wasted some of your time. – Citizen Mar 31 '16 at 8:27
0

I have the workaround...

If I change the UNC paths to include the FQDN version of the domain name rather than its NetBIOS name, then the drives appear correctly for both the Group Policy Preferences Drive Mappings and the AD account's user Home Folder.

i.e. \\domain.local\DFS-Share\path instead of \\domain\DFS-Share\path

(The wireless subnet's DHCP scope options include the WINS server addresses, a node type of Hybrid and the DNS suffix of the domain.)

It's nice to have a fix but I can't imagine this is expected behaviour?!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.