2

I'm tying to connect a Call Manager Express running on a Cisco 2900 series router to a Juniper EX3200 switch. I have both configured on VLAN 4, with both ports in access mode but when I connect the switch to the router, although I get the link light and the interface mode showing up/up on the Cisco side and the Juniper side, no traffic will flow.

After a bit of investigation, it looks to me like the Cisco doesn't have complete ARP information for the switch. Asking the Cisco to show its ARP table yields an incomplete record for the Juniper.

SHF_R2901#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.228.4.1              -   58f3.9c42.8278  ARPA   GigabitEthernet0/0
Internet  10.228.4.2              0   Incomplete      ARPA   

The port configuration is fairly straightforward. On the Cisco, the port is configured like this:

interface GigabitEthernet0/0
   ip address 10.228.4.1 255.255.255.0
   duplex full
   speed auto
!

and on the Juniper, the corresponding port is configured like this:

family ethernet-switching {
    port-mode access;
    vlan {
        members Voice;
    }
}

and the VLAN is configured like this:

Voice {
    vlan-id 4;
    l3-interface vlan.4;
}

and in interfaces/vlans/unit 4:

family inet {
    address 10.228.4.2/24;
}

I've tried setting the port speeds, setting proxy-arp to unrestricted on the Juniper Switch, adding the MAC address manually on the Cisco and nothing I've tried seems to let the Cisco router talk to the network.

Nothing else has a problem talking to the Juniper Switch - including other devices on VLAN 4 - the phone handsets for example happily connect, get IP addresses and then sit at registering because they can't reach the CallManager. Every other device on VLAN 4 can communicate with the others, and the switch.

Does anyone have any idea what I'm doing wrong here, or what I can do to get these to devices talking to each other? Any help would be very gratefully received as I'm now at the point where I don't know what else to try.


Update:

After the suggestion by SpacemanSpiff, I have done a bit more research and I'm now sure that the problem is at the Juniper end since if I plug a laptop into the port when it is configured as VLAN 4 I get the same incomplete ARP. I've tried the port on all the other VLANs and they work as expected so I'm at a bit of a loss as to what is special on VLAN 4.

For anyone who wants to see, the complete Juniper configuration (without passwords!): http://pastebin.com/E3YCWeqX

  • Forgive me if this seems dumb, as I don't do networking on a daily basis, but why does the router or the Call Manager Express need to communicate with the Juniper switch to begin with? The switches should be moving traffic, not consuming traffic. The Cisco 2900 would have an ARP entry for the Juniper if the Cisco was sending data to the Juniper for the Juniper's consumption, but that shouldn't be the case. The router and switches should be forwarding/switching traffic, not consuming it themselves. Perhaps you mean to look at the CAM table on the Juniper switch and not the ARP table? – joeqwerty Mar 30 '16 at 20:55
  • The Juniper switch is also acting a simple router between the VLANs and forwarding external traffic through a broadband bonding appliance for external connectivity (the site is in the middle of nowhere, and the best connection we can get is 5Mbps) so in this case, the switch is the default gateway for the CME (which although on a Cisco 2900 series, is not actually acting as a router). I'll amend the question to state that also none of the other devices on VLAN 4 can communicate with the CME even though they can communicate with each other. – Richard Comish Mar 30 '16 at 21:39
  • Can you post a little more o f the configuration form the Juniper side? I need some of the higher stanzas here. Also I suggest both duplex and speed be set at AUTO for both sides. – SpacemanSpiff Mar 31 '16 at 21:35
  • Actually if you can pastebin the entire Juniper config (sans passwords) i can definitely tell you whats up. If something is wrong with the Cisco side you can just plugin a laptop with a proper IP config and see if you can ping the router. – SpacemanSpiff Mar 31 '16 at 21:45
  • Certainly - I'll drop it in Pastebin tomorrow when I'm back at site. Thanks! – Richard Comish Mar 31 '16 at 22:09
0

EDIT: Replaced with relevant answer:

I'm fairly sure this stanza from the full config is your culprit. When this feature is involved, and especially when you've got it set to auto-add the voice VLAN as tagged to ANY access port, this prevents you from setting that VLAN as the native one while in access mode. You can get around this and leave this config intact by changing the port-mode to a trunk, and setting the voice VLAN as the native VLAN. This accomplishes basically the same config and should get things working for you.

ethernet-switching-options {
    voip {
        interface access-ports {
            vlan Voice;
            forwarding-class expedited-forwarding;
        }
  • Ah - sorry, that's me being stupid. I was testing it with a laptop plugged in. It works on VLANS 10, 11 and 12, but not 4. I'll change it to the new running config with it back on 4. – Richard Comish Apr 1 '16 at 14:03
  • Ahh okay so it's still not working. I'm fairly certain its the VOIP section of your config that is mucking you up here. It's expecting LLDP-MED to auto-kick the phones onto the voice VLAN, and so it may be expecting tagged traffic or something. I'd try setting the port as a trunk, and then setting the voice VLAN as the native vlan and see if that fixes you up with minimal config change. – SpacemanSpiff Apr 1 '16 at 14:11
  • An excellent suggestion - thankyou. Having set the port to be a trunk port with native ID 4 and told the call manager that it was on VLAN 4 as well, traffic has started flowing. That's excellent - thankyou again. – Richard Comish Apr 1 '16 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.