12

Trying to log in to an Amazon EC2 instance (running Windows Server 2012 R2) via RDP. It works, and I can connect, but having saved the credentials that worked, they never seem to be accepted on subsequent logins, always rejecting them and requiring me to reenter the password part manually.

Screenshot of login prompt dialog

Nothing about why it didn't work, just that it didn't — "Your credentials did not work" and "The logon attempt failed". Then I type in the same password as always and it works.

I can see that the credentials are in fact saved in the Credential Manager, and the right name is always filled in trying to log on. I can also see it trying the saved credentials for a split second before being presented with this dialog.

After googling around for an answer, I've tried several things, including using an IP address vs. a FQDN, doing that thing with the Group Policy editor ("Allow Delegating Saved Credentials with NTLM-only Server Authentication"), and checking the Group Policy on the remote side for anything unusual-looking. No dice.

How do I get it to accept the credentials it saved and not prompt me each time?

6

To be able to use saved credentials in this situation you need to do the following:

  • Open Group Policy Editor via cmd -> gpedit.msc
  • Navigate to Local Computer Policy\Computer Configuration\Administrative Templates\System\Credentials Delegation\
  • Open Setting Allow Delegating Saved Credentials with NTLM-only Server Authentication, set it to Enabled click on button Show... and in Show Contents window add Value TERMSRV/* Close all windows by pressing OK.
  • Run cmd and enter gpupdate command to update your policy.

Now you should be able to use your saved credentials.

Source: http://answers.microsoft.com/en-us/windows/forum/windows_7-security/remote-desktop-connection-not-using-saved/13a17d84-b008-4767-95fb-b891e9e6bc66?auth=1

or try the solution from link below: https://superuser.com/questions/604483/windows-7-remote-desktop-connection-save-credentials-not-working

| improve this answer | |
  • This worked for me. – Marc.2377 Apr 16 '19 at 19:24
4

On Windows 10:

In Credential Manager, within the Windows Credentials section, try deleting the credentials from the Windows Credentials sub-section and instead re-creating them in the Generic Credentials section.

| improve this answer | |
  • connection to win server 2019 repaired once and forever, thx! – ralf.w. Sep 11 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.