I have an EC2 machine with Ubuntu installed on it. On the machine, I have installed Node.js, MongoDB, and Github version of Parse Server.

I have created a database called euro. In this database, I've created a user using this code:

> use euro
switched to db euro
> db.createUser(
... {
... user: 'username',
... pwd: 'password',
... roles: [ { role: 'readWrite', db:'euro' } ]
... }
... )

Before migrating the app, I have noticed that in AWS EC2 Instances Managment page, you can see 2 IPs addresses: Public IP and a Private IP, so I used the Public IP.

In the Parse.com settings, I've clicked at the Migrate button, and entered this address:


and below the address field, it was written No reachable servers.

What can I do in order to solve it and to migrate the app to my EC2 Instance?

EDIT #1:
I have restarted my AWS server, so my Public IP address has been changed. I've tried to change my connection string to the new IP using this address:


But suddenly it shows No reachable servers.
What should I do in order to solve this problem? I want to migrate it as soon as possible.


Open the port 27017 in your EC2 security group.

After the migration is complete, you should remove this port from your EC2 security group, to prevent outsiders from reading or altering your documents.

| improve this answer | |
  • I did it, but it still not working – Ido Naveh Mar 31 '16 at 18:14
  • Just for info, I've enabled it on the inbound rules – Ido Naveh Apr 1 '16 at 8:53

Check if you have set the bindIp to in mongod.conf. MongoDB would be using the local IP which is a private IP and not accessible through outside. You can also check if you can access the DB with the public IP.

Try to connect to mongo db with the command.


This should resolve your issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.