2

Can anyone explain what I'm seeing here?

            Total    Copied   Skipped  Mismatch    FAILED    Extras
 Dirs :     20166     20166     20163         0         0         0
Files :    359490    359490         0         0         0         0
Bytes : 210.173 g 210.173 g         0         0         0         0

This makes no sense to me... 20163 Skipped directories, but Total and Copied match up 100% at 20166 each.

.\Robocopy.exe L:\US93_Users R:\US93_Users /e /zb /copyall /r:3 /w:10 /mt:32 /v /fp /log:r:\us93_Users.log /tee
  • I might know, but to make sure please add the command to your question and reformat it for proper viewing. – Daniel Apr 2 '16 at 6:40
  • Sorry, don't know why I didn't include it originally. – Steve Freeman Apr 2 '16 at 14:14
1

I have no evidence, but I believe this is a simple display bug in the job summary. It is caused by the usage of the /mt switch.

Other people noticed that "the progress monitors don’t seem accurate in multi-threaded mode".

If you don't need a multi-threaded value of 32, you can remove the switch altogether and robocopy will fallback to a multi-threaded value of 8 and produce correct job summaries. On most machines that makes no difference anyway, I assume.

  • Yeah, I'm going to have to go with that as an explanation...I didn't see any skipped items in the log either. It's odd, I've used those same switches for other folder moves, and I've never had that happen. – Steve Freeman Apr 2 '16 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.