When I modify /etc/nsswitch.conf, is there an "nss" daemon I should restart? I am not referring to modules such as mdns & nis.


No you probably don't (other than what David said, and maybe ypbind, but you said not NIS). The nsswitch.conf file isn't for a daemon in particular, it is actually a file used by the C library for various system calls.

| improve this answer | |

You may have nscd (Name Service Caching Daemon) running, which you may need to restart, otherwise it's unlikely. Certain daemons might cache get*() function call results and may need restarting.

| improve this answer | |
  • 1
    Well since my answer as accepted I have to give David the upvote :-P – Kyle Brandt Oct 21 '09 at 17:30
  • \o/ cheers. now I feel the need to upvote you for your generosity. – David Pashley Oct 21 '09 at 17:32
  • Thanks guys. I can see that nscd isn't installed/running by default on Ubuntu. – jldupont Oct 23 '09 at 15:24
  • 1
    That's probably a good thing. NSCD just normally causes more problems than it solves. :) – David Pashley Oct 23 '09 at 16:26
  • Rather than just restart, you could disable the thing. I would restart my NSCD and successfully resolve host names, then a short while later, my resolution would fail. This happened consistently. – palswim Apr 1 '16 at 19:32

Be aware that existing processes will not be aware of the changes to nsswitch.conf. The nsswitch.conf(5) page states, "Within each process that uses nsswitch.conf, the entire file is read only once; if the file is later changed, the process will continue using the old configuration."

| improve this answer | |
  • 6
    So what's a person to do? Reboot? – Ken Williams Nov 13 '13 at 20:46
  • 3
    @Ken: Sadly, this appears to be the case. – Ron Smith May 2 '14 at 21:20
  • 2
    Installing nscd and doing sudo service nscd restart && sudo service network-manager restart removes the need to reboot for me. – 01AutoMonkey Jun 29 '17 at 17:10
  • Ubuntu 16: Failed to restart nscd.service: Unit nscd.service not found – Paulo Pedroso Jan 31 '19 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.