4

We have a 6-server TS farm running Server 2008 R2 and using a WSUS server to do updates. Group Policy for the farm has updates configured to automatically download and install as soon as they're approved, but automatic reboots are disabled. The operation is 24x7 and the servers are on a rolling drain/reboot schedule of their own. The desired behavior is that updates install and sit pending the next scheduled reboot. Users are not supposed to see any notifications whatsoever.

I approved a new batch of updates yesterday, and this morning users are calling the help desk reporting seeing this on their screens:

enter image description here

The Restart button is grayed out (thank god!), but I don't know if this is new behavior or if users have just never reported it before. I double-checked Group Policy to verify I have the "Allow non-administrative users to receive update notifications" set to disabled, and it is:

enter image description here

I also ran a gpresult on the servers themselves, and they are receiving and (allegedly) applying the policy:

enter image description here

What can I do to stop this notification from appearing to users? It nags them to perform an action that they do not have the ability to do, and it's generating help desk calls. It's also annoying them because in the best-case scenario, they could be seeing this popup every 4 hours for up to a week.

  • one thing I don't see in your Group Policies is whether they are set on the User or Computer node. – ETL Apr 8 '16 at 2:28
1

This appears to have been answered previously Disable restart after update prompt for server 2008 R2. The policy you mention will not stop restart notifications.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.