1

Before I start I want to apologize if my english isn't 100% correct since it's not my main language.| So, here is my problem:

I have a Windows Server 2012 R2 server with the GUI removed. Including the payload. When I try to reinstall it it gives me an error that the source is incorrect. However I tried this too on a fresh server, uninstalled the gui, then peformed these steps and there it did work!

This is what I've tried:

Install-windowsfeature cmdlet
Install-windowsfeature cmdlet with install.wim as source
DISM with install.wim as source

Uninstalling all KB's and then trying all the above again.

I've tried the DISM with Install.wim as source on the test server and there it worked. However on the server with this issue it gets stuck at 67,6% and then fails saying it can't find a source.

This is how I did DISM:

<#Upgrade Windows Server 2012 R2 Core to GUI with ISO

<# Make a folder for install.wim
mkdir c:\w2012\image

<# Copy the install.wim from the Windows Server 2012 R2 ISO to the machine

copy $cd\sources\install.wim c:\w2012\image

<# Retreive the name or index number of the image

<# Server Standard is Index:2

<# Server Datacenter is Index:4

DISM /Get-ImageInfo /ImageFile:C:\w2012\image\install.wim

<# Create a folder to mount the install.wim

mkdir c:\w2012\mountpoint

<# Mount install.wim in mountpoint

DISM /Mount-Image /Imagefile:C:\w2012\image\install.wim /index:2 /MountDir:C:\w2012\mountpoint /readonly

<# Upgrade to full GUI

DISM /online /enable-feature /featurename:Server-Gui-Mgmt /featurename:Server-Gui-Shell /featurename:ServerCore-FullServer 
/source:C:\w2012\mountpoint\windows\winsxs

<# done.

However I get the following error:

The source files could not be downloaded. Use the "source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077.

I have tried all different indexes but with no effect.

Also, a way to pull the configuration and paste it on a GUI server would also be nice, but upgrading it to GUI has priority. But if you know a way please let me know.

  • The server likely got a build version upgrade and thus the old install sources are outdated. Can you check build numbers? – TomTom Apr 8 '16 at 9:08
  • I've always used the mount-wim instead of mount-image Dism /mount-wim /WimFile:<drive>:\sources\install.wim /Index:2 /MountDir:c:\isofiles /readonly Install-WindowsFeature Server-Gui-Mgmt-Infra, Server-Gui-Shell –Restart -Restart –Source c:\ISOFiles\windows\winsxs – Mass Nerder Apr 8 '16 at 20:36
  • Hello, I've tried it with different build versions and the same on a test server and they both worked. Also the mount-wim instead of mount-image didn't work – j. Koelewijn Apr 11 '16 at 8:36
1

I ran into the same issue today. What happened was person A installed 2012 R2 Core on the server with iso image A. Person B came along and tried to add the GUI using files extracted from iso B. The OS gave the error that the source files could not be found. We extracted the files form iso A and tried again and the install worked.

  • To clarify iso A and iso B were different builds and that was the issue – Mass Nerder Apr 22 '16 at 17:10
0

Here's how I got my Server 2012 R2 Core system moved over to the GUI. Hopefully it helps someone!

  1. Checked C:\Windows\Logs\CBS\CBS.log after trying to install the feature and saw payload files were missing. Example: "Failed to find payload files, component:amd64_microsoft-windows-w..client-ui.resources_31bf3856ad364e35_7.9.9600.18039_en-us_a9315b328356154d, file: wushareduxresources.dll.mui"
  2. From another Server 2012 R2 system that had the GUI and was fully patched, I copied over the C:\Windows\WinSxS folder to a temp folder on my Server 2012 R2 Core server (My folder was C:\TempTest). NOTE: I actually had to copy over the WinSxS folder from two different servers because the first time I tried to enable the feature I saw the same payload problems in the CBS.log except it would point to a different version (e.g. amd64_microsoft-...7.9.9600.18066..).
  3. On the server core system: Dism /Online /Enable-Feature /All /FeatureName:Server-Gui-Mgmt /Source:C:\TempTest /LimitAccess
  4. After it installed, it required a reboot
  5. When it came back up, got the cmd prompt and after about a minute Server Manager popped up (some GUI management features are available after “Server-Gui-Mgmt” feature is installed)
  6. I then used Server Manager to add the “Server Graphical Shell” feature which is under the “User Interfaces and Infrastructure” section and rebooted. You can do this through the command line again with the FeatureName "Server-Gui-Shell".
  7. When it came up, had the full GUI and then installed GUI-related Windows Updates from over the years
-2

No possible solution can be found ( I had this posted on other Fora too ) so now we are going to try to copy the configuration to a fresh installed GUI server.

  • The original poster may not be able to solve their individual problem, but broadly it is possible as pointed out by posters above. – Matthew Wetmore Jan 27 '18 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.