2

I can't seem to find anything about this anywhere.

I'm using Windows 10 (not Insider Preview), and have the latest updates.

Whenever I attempt to remotely connect to any server using RDP, I see the standard window:

The normal RDP window -- nothing funky here

However, when I click connect, I expect to be presented with a username and password dialog. Instead, I get that same window -- without the ability to enter a username or password:

WTF? Where are the actual text boxes?

It's truly bizarre, and I haven't even been able to find results googling for it.

Any advice would be greatly appreciated!

Update: This dialog also appears when using an alternate RDP program such as RDCMan. When I enter credentials correctly in that program, it works. When I enter incorrect credentials and the credential dialog pops up, it looks as it does in my screenshot.

What I've Tried So Far

Per some great suggestions below, I've tried the following things:

  • Checked Credential Manager. I opened the Windows Credential Manager to see if anything was stored there. While there were some "generic credentials" that appeared to be related to MS Office, there were no windows credentials stored:

enter image description here

  • Checked to make sure I had the latest updates. I've updated several times since.
  • Attempted to use "Show Options" to pre-populate the username. Unfortunately, when prompted for the password portion, the screen was still blank.
  • Did you ever find a solution to this? I'm having a very similar issue. – John Jan 23 '19 at 20:42
1

It sounds like you have Cached Credentials.

You can try to fix this by going to start, Type "Control Panel", Hit enter

in Control Panel go to the upper right hand corner of the window and click the drop down and choose large or small icons then click the Credential Manager icon.

In Credential Manager choose Windows Credentials bellow that there should be a list of Cached windows credentials.

Choose the one that has to do with the server you are trying to connect to (usually has the server name or IP listed) click the down arrow and click "remove" then click yes and try to connect again.

If that doesn't work you can edit your RDP shortcut and remove or add Credentials if you click the "Show Options" button in the picture you provided

|improve this answer|||||
  • Hi! First off, thanks for making me aware of this area -- don't know how I hadn't seen that before Secondly, I looked and I don't appear to have any cached windows credentials, and none of the credentials listed otherwise involved RDP or the server as far as I could tell. Note: this also happens when a login fails, e.g. using another app for RDP if I enter the wrong credentials. (I'll update the question to include that) – SeanKilleen Apr 8 '16 at 13:22
  • it might look something like "SERVERNAME/PC-NAME" – TheStarvingGeek Apr 8 '16 at 13:25
  • 1
    Wanted to follow up on this to say that while it was a good and informative potential answer, it didn't solve my problem. This login prompt appears this way for me on machines I've never connected to before, and also credentials manager says I have no cached windows credentials, and I find nothing remotely related to RDP in the "generic credentials" section. Thank you for the attempt though, @TheStarvingGeek! – SeanKilleen May 11 '16 at 14:27
1

On my Windows 10 machine, I get the same view, but when I press "Show Options" button, it gives me the textbox to enter username.

Also, in the username textbox, you can provide credentials as "Servername\username"

|improve this answer|||||
  • How does this answer the question? – Pierre.Vriens May 11 '16 at 15:03
  • @Pierre.Vriens I believe it was an attempt to get me to a place where I could at least use the tool to login (which I appreciate). – SeanKilleen May 11 '16 at 15:21
  • Thanks for the attempt at help! While I am able to enter the username, I still receive the blank screen upon connecting when I would normally be prompted for a password. – SeanKilleen May 11 '16 at 15:23
1

I had the same issue; and the only workaround I could figure out (from earlier experiences) was this:

  1. Press Windows Start
  2. Search for Credential Manager
  3. When in Credential Manager, press "Add a Windows credential"
  4. Enter the machine you want to connect to with the associated username and password
  5. You should now be able to "sign in" without the malfunctioning prompt (if your credentials are valid)

Hope this help you.

|improve this answer|||||
0

I ran into this behavior just last week. I was trying to connect to a machine that was in the process of shutting down/rebooting. Once the server was back online, things worked as expected.

|improve this answer|||||
  • Unfortunately I can confirm that this isn't the case -- also happens to me on RDP at the same time I'm connected from another machine, no shutdown / reboot is in progress. Still a good lead though, thanks! – SeanKilleen Apr 8 '16 at 15:32
0

The solution I found is to edit the Default.rdp or the rdp file in notepad for the connection in question and add the following option:

enablecredsspsupport:i:0

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.