0

How can I configure Windows 10 to send an error report to an internal Corporate Error Reporting (CER) server while connected only to an internal network that has no internet access?

Windows pops up a dialog box when attempting to check for a solution for a problem: Problem Reporting, "Connect to the Internet, or try again later - Solutions are available online only. Make sure you're online and try again. If you still can't see the solution, the service might be temporarily unavailable."

I'm able to switch networks (from the internal restricted network to an outside network that allows internet access) by physically switching the cables and running ipconfig /release and then ipconfig /renew and all of the error reports immediately send to the CER server.

I'm able to ping and map network paths to/from the CER server while on either the restricted or external networks.

It seems to me that the idea of an internal CER server is to allow errors to be reported internally and should have no need for an internet connection, just a valid network connection to a CER server. Any help would be greatly appreciated!

My setup info: The CER server is setup on Windows Server 2012 R2 w/ SQL Server 2014 SP1 and System Center Operations Manager 2012 R2. The specific part of SCOM that I'm interested in is Agentless Exception Monitoring (AEM). I've configured Windows 10/7 systems to send reports using group policy and occationlally by manually editing the registry. For the sake of this question, I've only applied settings directly generated from SCOM into an .adm file to enable AEM. I'm happy to answer any clarifying questions.

TechNet Article (old) form MS that leads me to believe this is possible:

The best method to use to prevent the automatic flow of error reporting information to and from the Internet is to redirect error reports to a server on your intranet by using Group Policy and to set up Corporate Error Reporting (CER).

2
  • Why did you delete the last question you posted on this topic? – EEAA Apr 8 '16 at 21:12
  • I deleted the last question because it was more about having the setup correct -- this is not about the setup, that is working -- it's about a specific issue where when not connected to the internet, Win 10 won't attempt to send error reports. They were similar -- but this is more reproducible and a more direct question. – PerryC Apr 8 '16 at 21:16
1

Have you made the requisite GPO change in Windows Components\Windows Error Reporting\Advanced Error Reporting Settings\Configure Corporate Windows Error Reporting - and have you made this change on GPO that affects your restricted network?

6
  • Yes, I've applied all of the proper group policy settings. I can verify this because on some machines, Windows will (somehow -- I wish I knew exactly how) claim to have an Internet connection and happily send error reports. Other machines, with the same settings (as far as I can tell), don't claim to have an Internet connection, and don't send any error reports. (Also -- on the machines that claim to have an internet connection -- I can't ping google and can ping my cer server -- just like on the machines that don't have "Internet access"). – PerryC Apr 11 '16 at 18:33
  • Okay. If you compare the gpresult outcome on a working vs non-working machine, are the results identical? – vigilem Apr 11 '16 at 18:52
  • The results aren't completely identical -- although the settings around firewalls, networking, and error reporting are identical. For clarification, this line of debugging is very valid -- but not really what I'm asking here. I'm curious if this can be done without Windows needing to find an internet connection in the first place if we know we're connected. – PerryC Apr 11 '16 at 20:38
  • 1
    Understood. I'll say, then, based on your GPO configuration, the answer 'should' be yes - but obviously it's not working in total for you. The definition of the GPO settings (as I read them) implies that as long as the PC in question can reach the CER server, it should not require an Internet connection proper. My apologies for not being more helpful. – vigilem Apr 12 '16 at 13:22
  • You did your best -- no apologies needed. This is a harder question to answer, hence the bounty. You did contribute a reasonable debugging attempt, which is why I up-voted your answer. Thanks anyways. – PerryC Apr 12 '16 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.