1

I try to run yum update but I have three errors. I try to run the commands suggested but change nothing. How I can solve this errors?

--> Processing Dependency: libzip.so.4 for package: php-pecl-zip-1.13.2-1.el6.remi.5.6.i686
--> Finished Dependency Resolution

Error: Package: php-gd-5.6.20-1.el6.remi.i686 (remi-php56)
Requires: gd-last(x86-32) >= 2.1.1

Error: Package: php-gd-5.6.20-1.el6.remi.i686 (remi-php56)
Requires: libgd.so.3

Error: Package: php-pecl-zip-1.13.2-1.el6.remi.5.6.i686 (remi-php56)
Requires: libzip.so.4
2

I solve using:

yum install php-gd --enablerepo=remi,remi-php55
1

You don't even say what operating system you're running, one of the more likely issues is that you are missing 'extra packages for enterprise linux' or EPEL repository. you can confirm what repositories you are tracking using the repolist command

yum repolist

if you are using RHEL then you should register you server with them and seek support from Red Hat as you entitled to with you license, or you can install them from the links below.

if you are running RHEL/CentOS you can install the EPEL repo using rpm as noted in the examples below, but the preferred approach is to install the rpm file with 'yum install epel-release-7-7.noarch.rpm'

RHEL/CentOS 7 64-Bit

# wget http://dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-5.noarch.rpm
# rpm -ivh epel-release-7-5.noarch.rpm
RHEL/CentOS 6 32-64 Bit

RHEL/CentOS 6 32-Bit

# wget http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm
# rpm -ivh epel-release-6-8.noarch.rpm

RHEL/CentOS 6 64-Bit

# wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
# rpm -ivh epel-release-6-8.noarch.rpm

RHEL/CentOS 5 32-64 Bit

# wget http://download.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
# rpm -ivh epel-release-5-4.noarch.rpm

RHEL/CentOS 5 64-Bit

# wget http://download.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm
# rpm -ivh epel-release-5-4.noarch.rpm

RHEL/CentOS 4 32-64 Bit

# wget http://download.fedoraproject.org/pub/epel/4/i386/epel-release-4-10.noarch.rpm
# rpm -ivh epel-release-4-10.noarch.rpm

RHEL/CentOS 4 64-Bit

# wget http://download.fedoraproject.org/pub/epel/4/x86_64/epel-release-4-10.noarch.rpm
# rpm -ivh epel-release-4-10.noarch.rpm
1

libzip-last and gd-last are in remi-safe repository which is enabled by default once you have install the remi-release (auto-configuration) package.

Remember to check the Configuration Wizard instruction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.