-2

I have a server with Exim4 It manage the domain example.com

A desktop user which running Thunderbird, is using the SMTP of his ISP (it don't using the server's smtp for some pertinent reasons).

The SMTP outgoing server is authentified by SSL, on 587 port.

When the user, owner of the mailbox user1@example.com, send a email to anybody, it's working without problem.

But if user1@example.com try to send a message to user2@example.com, it received an error message like this :

    This is the mail system at host slow1-d.mail.gandi.net.
I'm sorry to have to inform you that your message could not
be delivered to one or more recipients.

                  The mail system

<user2@example.com>: host domain.com[213.xxx.xxx.xxx] said: 550
smtp auth requried

Yes, the writing error is real on "requried" ;)

And on exim4 log I have this :

2016-04-13 12:06:42 H=slow1-d.mail.gandi.net [217.xxx.xxx.xxx] F=<user1@domain.com> rejected RCPT <user2@example.com>: smtp auth requried

What's going wrong ?

0

That all because of the next ACL rule:

deny message = smtp auth requried
     sender_domains = +local_domains
     !authenticated = *

But you can't disable it because your MX become an open relay for every message sent from your domain. The best solution is to submit directly from client to the MX. While port 25 can be blocked by ISP ports 465 and 587 sould be opened for SMTPS/SMA. You have to configure clients properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.