0

If I use smtp auth for send mail on mail client , the reply-to address received by destination is the same used in smtp authentication. I must authenticate with the same . It is forced by exim config. it's possible to change?

my config is :

POP3: mail.xxx.xxx user:abc@xxxx.xxx

SMTP: mail.xxxx.xxx auth with user:xyz@xxxx.xxx

the destination reply-to address is abc@xxxx.xxx but I want xyz@xxxx.xxx

0

Your email composer should allow you to add a Reply-to header. This is different from the From header which should match the user you authenticate as. Alternatively, setting a Sender header to the user you are authenticating as should allow you to use a different From header. Either the Sender or From address should match the envelope from address.

It would be best to leave your Exim configuration alone. You will have the least delivery problems if when you compose the message you either:

  • add Sender: header with the address you are using to authenticate and set the From: address to the address that should receive replies; or
  • add a 'Reply-To:` header with the address that you want to receive replies and set the From address to the address you are authenticating with.

Exim will enforce the Sender header rules if local_from_check is true (default). Related settings include local_from_prefix, local_from_prefix, qualify_domain and untrusted_set_sender. You should be able to avoid the fixups if you authenticate with a user listed in trusted_users or belonging to one of the trusted_groups. It is also possible to conditionally bypass the fixup with the suppress_local_fixups flag. The Sender line processing is documented in the Exim Specification

If you want to risk delivery issues, you can modify your Exim configuration to not ensure you have the correct headers. The simplest option is to add a line to the top of your Exim configuration reading:

untrusted_set_sender=false
| improve this answer | |
  • Thank you Bill, but could you please let me know ( in simple words) what changes in the Exim configuration will help me to achieve this. – Techiescorner Apr 14 '16 at 15:41
  • @Rinshad I've updated the answer. If you change your Exim configuration it is likely your mail will be treated as Spam.. Fix the issue in your email composer. – BillThor Apr 14 '16 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.