0

Suddenly my server log shows:

An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full

And I googled and found these links as suggestions to resolve this issue:

https://superuser.com/questions/842585/getting-system-lacked-sufficient-buffer-space-or-because-a-queue-was-full
Getting "An operation on a socket could not be performed because the system lacked sufficient ..." when server access the internet

They say that you can change the value of TcpTimedWaitDelay in registry and the problem might go away. However, I can't find this value on Windows Server 2012. I simply can add it. But I can't be sure if it truly helps or not, because I truly don't have an idea of how to measure the result of this key.

What should I do? Should I add that key to the registry?

1

TcpTimedWaitDelay is fully supported in Windows Server 2012

You may have to set the StrictTimeWaitSeqCheck as well, for TcpTimedWaitDelay to be of effect:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters] "StrictTimeWaitSeqCheck"=dword:00000001

Setting or changing these will require a reboot for the changes to be in effect.

There is no way of telling if these changes will solve your particular problem, but they are easily reversible if not.

HTH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.