1

I know Debian Squeeze (v6.0) is EOL and LTS officially ended in Feb. However, i have a few squeeze server (cant be upgraded for now) and i must monitor those Via SNMP. My problem is that all squeeze mirrors were removed and i for the life of me cant find the snmp daemon. I tried using the Wheezy source list, but im getting errors about dependencies it needs but wont be installed (see below). I assume because i need to perform a glibc update, but i cant do that (and risk breaking its current apps) . Does anyone know where one can find just the snmp daemon for squeeze?

Thanks!

root@localhost:~# apt-get install snmpd
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
aptitude : Depends: libapt-pkg4.12 (>= 0.9.7.6) but it is not going to be installed
Depends: libboost-iostreams1.49.0 (>= 1.49.0-1) but it is not going to be installed
Depends: libept1.4.12 (>= 1.0.9) but it is not going to be installed
Depends: libstdc++6 (>= 4.6) but 4.4.5-8 is to be installed
Depends: libtinfo5 but it is not going to be installed
Recommends: aptitude-doc-en but it is not going to be installed or
aptitude-doc
Recommends: apt-xapian-index but it is not going to be installed
Recommends: libparse-debianchangelog-perl but it is not going to be installed
libc6 : Depends: libc-bin (= 2.11.3-4) but 2.13-38+deb7u10 is to be installed
locales : Depends: glibc-2.13-1
snmpd : Depends: libsnmp15 (>= 5.4.3~dfsg) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Edit

I just wanted to update to describe what i'm seeing. I have the correct entry and "apt-get update" runs without an issue. I suspect that the issue now is that i had run "apt-get update" using the wheezy source. How can i resolve this?

source.list entry

deb http://archive.debian.org/debian/ squeeze contrib main non-free

Apt-Get Update

root@Localhost:~# apt-get update
Hit http://archive.debian.org squeeze Release.gpg
Ign http://archive.debian.org/debian/ squeeze/contrib Translation-en
Ign http://archive.debian.org/debian/ squeeze/contrib Translation-en_US
Ign http://archive.debian.org/debian/ squeeze/main Translation-en
Ign http://archive.debian.org/debian/ squeeze/main Translation-en_US
Ign http://archive.debian.org/debian/ squeeze/non-free Translation-en
Ign http://archive.debian.org/debian/ squeeze/non-free Translation-en_US
Hit http://archive.debian.org squeeze Release
Hit http://archive.debian.org squeeze/contrib i386 Packages
Hit http://archive.debian.org squeeze/main i386 Packages
Hit http://archive.debian.org squeeze/non-free i386 Packages
Reading package lists... Done

1

https://www.debian.org/distrib/archive

If you are using APT the relevant sources.list entries are like:
deb http://archive.debian.org/debian/ hamm contrib main non-free
or
deb http://archive.debian.org/debian/ bo bo-unstable contrib main non-free

| improve this answer | |
  • Same issue. My source list now has "deb archive.debian.org/debian squeeze contrib main non-free". Im running "apt-get update" which seems to go thru fine, but "apt-get install snmpd" returns the same error – Joe Apr 14 '16 at 20:55
  • Maybe because i ran an APT update using the wheezy source list? If so, how do i revert? – Joe Apr 14 '16 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.