0

I have a centOS minimal installed and it the sound drivers loaded. I would like to remove all the sound drivers from my server. How can I do that? following are the command outputs from my server.

cat /proc/asound/cards 0 [AudioPCI ]: ENS1371 - Ensoniq AudioPCI Ensoniq AudioPCI ENS1371 at 0x2080, irq 17

lsmod | grep 'snd' snd_ens1371 25243 0 snd_rawmidi 30871 1 snd_ens1371 snd_seq_device 14356 1 snd_rawmidi snd_ac97_codec 130605 1 snd_ens1371 ac97_bus 12730 1 snd_ac97_codec snd_pcm 105835 2 snd_ac97_codec,snd_ens1371 snd_timer 29639 1 snd_pcm snd 83425 6 snd_ac97_codec,snd_timer,snd_pcm,snd_rawmidi,sn _ens1371,snd_seq_device soundcore 15047 1 snd

lspci | grep -i audio 02:03.0 Multimedia audio controller: Ensoniq ES1371 / Creative Labs CT2518/ES1373 (rev 02)

  • What output give you commands systemctl | grep alsa systemctl | grep sound systemctl | grep pulse ? – fghj Apr 15 '16 at 12:14
  • systemctl | grep sound sys-devices-pci0000:00-0000:00:11.0-0000:02:03.0-sound-card0.device loaded active plugged ES1371 / Creative Labs CT2518/ES1373 (AudioPCI 64V/128 / Creative CT4810/CT5803/CT5806 [Sound Blaster PCI]) sound.target loaded active active Sound Card – Vishnu Apr 15 '16 at 12:22
  • The other two commands are not displaying any information – Vishnu Apr 15 '16 at 12:23
1

You can add such lines to /etc/modprobe.d/disable-sound.conf

blacklist snd_ens1371
blacklist soundcore
blacklist snd

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.