2

I have a serious problem with a bunch of computers. They're all equiped with a ASUS P9X79 Pro Mainboard, running Windows 7 Ultimate and refuse to boot starting with one machine yesterday morning and 4 more today.

All showing the same Symptom: Reboot or Insert proper boot decvice

I got one of them and reinstalled Windows 7 Ultimate, which worked absolutely fine. Afterwards I installed the newest drivers from the ASUS website. Then I searched for Updates and after about 2 hours Windows Update told me it has found 220 new Updates. So I installed them which took me another 1.5 hours. After all the updates were installed, Windows required me to reboot to complete the process, so I restarted. Doing so resulted in a screen showing Stage 1 of 5, then 2 of 5 and so on. At Stage 5 of 5 it stalled at 32% for about 30 minutes, then rebooted. Again it showed Stage 5 of 5 but that time the percent numbers climbed rapidly to 100%. Another reboot followed, which resulted in Reboot or Insert proper boot decvice

When the first machine came up whith that problem, i expected a damaged hard drive, but now with 5 of these machines, equiped with the same type of mainboard and the same behavior I belive that one of those Windows updates killes the boot sector. Also one of the operators of one of the affected machines told me that his machine was installing updates on shutdown the evening before the problem occured.

I tried to boot from the Windows 7 Ultimate Install disk, selected Repair -> command prompt, where i hoped to fix the problem with BootRec.exe /fixmbr but with no luck. Also if I do BootRec.exe /ScanOS I get 0 found Installations.

But if I do a dir on drive C: I see the Windows installation.

Can anybody give me a hint on how to fix those installations?

Update 26.04.2016:

I've got one of the machines on my desk today and it refused to boot. After that I went to the BIOS to see that there are more boot options then in the past. The new entry is called "Windows Boot Manager". Is it possible that a windows update can create a new boot option? I know that for sure because these machines tended to loose their BIOS settings once in a while and I had to reconfigure that over the phone a few times and there was no "Windows Boot Manager" entry. This is so weird because i recognized that entry on the first machine i got back and changing the boot order to that one didn't make the machine boot. But for some unknown reason this time it worked!?

Any way, i will try to figure out which update causes this kind of Problem as suggested by @Massimo

  • 1
    did you run bootrec /fixboot – Sum1sAdmin Apr 15 '16 at 15:15
  • Yes, i did that! Both bootrec /fixmbras well as bootrec /fixboot respond with The operation completed successful, but at the same time bootrec /scanos respondes with Total identified Windows installations: 0 – Bouni Apr 18 '16 at 6:10
  • NOT voting to close here. This is not some guy's home machine (which would be a better fit for SuperUser): this is the same problem happening on several machines with identical hardware and software configuration, in what likely is a business environment. – Massimo Apr 25 '16 at 20:36
  • @Massimo you're right, they are machines in our company. – Bouni Apr 26 '16 at 7:54
  • The boot entry "Windows Boot Manager" is used in UEFI systems; they use a modular architecture which requires the installed OS to provide its own extension to the system firmware, and is thus listed in the available boot options. If yours are UEFI systems, having that boot entry is normal; and it should be there in order for Windows to boot. – Massimo Apr 26 '16 at 22:32
2

This seems to be the root cause of my problems: http://www.heise.de/newsticker/meldung/Windows-7-Update-verhindert-Boot-auf-Asus-Mainboards-3198586.html (Sorry, the article is in german). Interestingly i never saw the red warning which is shown in the articel for some strange reason!?

| improve this answer | |
  • Microsoft recently changed the status of KB3133977 from "optional" to "recommended". So its an old patch, but because of that change it is now included by default. asus.com/support/FAQ/1016356 – Clayton May 12 '16 at 13:31
1

Do you recall if any of the updates you installed were a driver update for your mass storage controller? If a new/updated device driver for your mass storage controller is not working as expected, it could prevent Windows from booting off the hard drive.

I would do another test. But this time before applying Windows Updates, disable driver updates using this Microsoft guide, How to stop Windows 7 automatically installing drivers.

| improve this answer | |
0

If you suspect an update is causing this issue (an assumption I agree with), here's how I'd trobuleshoot it:

  • Install a fresh copy of Windows 7 on one of those machines.
  • Apply all updates released before April 2016.
  • Confirm the machine is still working; if it isn't, repeat the same process but stop earlier in the update list (f.e. before March 2016).
  • Perform a new Windows update check; take not of all proposed updates.
  • Apply the remaining updates one at a time, rebooting between each update and the next one.
  • Proceed until you identify the update which breaks the boot process.

Once you have identified which update is actually responsible for your problem, then you can open a support case with Microsoft.

| improve this answer | |
-2

basically it is a hardware error on your machine which is found in case of system can't detect Hard Disk Drive. Anyway you have need to 1. Reinsert HDD once again (both cable data cable as well as power cable). 2.configure 1st boot device Device HDD in boot order & then save it. 3.Check once again in BIOS setup if configuration is changed automatically replace C-MOS battery. 4.i hope your issue is fix now & if possible install update manually, avoid specific update which is related to hardware configuration or updates.

| improve this answer | |
  • 1
    Very unlikely to be a hardware error, since it happened on 5 machines which were working fine before instaling updates. – Massimo Apr 25 '16 at 21:58
  • As you wish boss but never forget "Some time technology make trouble" – Manjeet BhardwaJ Apr 26 '16 at 18:34
  • As you wish boss but never forget "Some time technology make trouble". its possible that there are some compatibility issue with Ultimate edition of windows 7. Even many time i had recently faced an issue with windows 7 Ultimate edition in which system first time a laptop working fine after fresh installation but after restart OS get corrupted. May be if you use any other OS or edition of OS your issue have been fix. Thanks. – Manjeet BhardwaJ Apr 26 '16 at 18:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.