2

I am trying to install centos 7 using kickstart on vmware 12. I have downloaded iso and installed many virtual machines using the same iso package.

I am getting error: Error setting up base repository

Steps I am performing for kickstart.
mount /dev/sr0 /webdir/rhel //CD rom iso is mounted here
chown -R root:root /website/rhel
chmod 755 /webdir/ks.cfg

My kick start file

#version=RHEL7
# System authorization information
auth --enableshadow --passalgo=sha512

# Use CDROM installation media
#cdrom
url --url http://192.168.1.201/rhel
# Use graphical install
graphical
# Run the Setup Agent on first boot
firstboot --enable
ignoredisk --only-use=sda
# Keyboard layouts
keyboard --vckeymap=us --xlayouts='us'
# System language
lang en_US.UTF-8

# Network information
network  --bootproto=static --device=eno16777736 

--gateway=192.168.1.1 --ip=192.168.1.200 --

nameserver=192.168.1.1 --netmask=255.255.255.0 

--noipv6 --activate
#network  --hostname=server.homedomain.com
# Root password
rootpw --iscrypted $6$ozwaEbpRPt30cDvE

$AvQIjqHZAkFSCqc8vfO.Kta6QPw7AXTNFXtNASV2HGU9pnc

lcNcpzjvoe4wFc9bdoo8Kyfe01tuauM0k9s3pn/
# System timezone
timezone Asia/Karachi --isUtc --nontp
user --name=atif --password=asif10
#user --name=asif --password=

$6$DThpCq/Gemo2s3DL

$3y4CtyJYO.gvZ67acOskcOvKNUJiYlz3hEUF/LoRu0FDDIc

u6rVS5OFVfLygbDjLOjkANvs5aCupKawyRw3jU1 --

iscrypted --gecos="Muhammad Asif"
# X Window System configuration information
xconfig  --startxonboot
# System bootloader configuration
bootloader --location=mbr --boot-drive=sda
# Partition clearing information
clearpart --none --initlabel
# Disk partitioning information
part pv.196 --fstype="lvmpv" --ondisk=sda --

size=16900
part /boot --fstype="xfs" --ondisk=sda --

size=1024 --label=boot
volgroup centos --pesize=4096 pv.196
logvol /home  --fstype="xfs" --size=1024 --

label="home" --name=home --vgname=centos
logvol swap  --fstype="swap" --size=1024 --

name=swap --vgname=centos
logvol /  --fstype="xfs" --size=14848 --

label="root" --name=root --vgname=centos

%packages
@base
@core
@desktop-debugging
@dial-up
@directory-client
@fonts
@gnome-desktop
@guest-agents
@guest-desktop-agents
@input-methods
@internet-browser
@java-platform
@multimedia
@network-file-system-client
@networkmanager-submodules
@print-client
@x11

%end

%addon com_redhat_kdump --disable --reserve-

mb='auto'

%end

Please suggest a solution for this.

2
  • are folding in original file, or just a typo from copy/paste (network line, password line) ? – Archemar Apr 18 '16 at 7:58
  • this is the orignal anaconda-ks.cfg file copied from /root/ , just added url line to make it work over the network. – moona khan Apr 18 '16 at 7:59
1

you set up defines a CD install, but your kick script defines a network location.

Steps I am performing for kickstart. mount /dev/sr0 /webdir/rhel //CD rom iso is mounted here chown -R root:root /website/rhel chmod 755 /webdir/ks.cfg

# Use CDROM installation media
#cdrom
url --url http://192.168.1.201/rhel

shouldn't it be something like:

# Use CDROM installation media
cdrom
repo --name="RHEL7" --baseurl=cdrom:sr0
4
  • I want to peform network installation. once the ks.cfg file is downloaded on the client , it will search for dvd content on the mentioned path ................ url --url 192.168.1.201/rhel ............... I dont want to install it from the local cd rom – moona khan Apr 18 '16 at 11:22
  • it that case I would look at your apache config, is directory listing enabled - can you view it from a browser? - it would also need to be PXE image and not an ISO – Sum1sAdmin Apr 18 '16 at 11:34
  • apache is working fine. as i am able to download ks.cfg onto the client. the only error was related to installation source.. – moona khan Apr 18 '16 at 17:41
1

I have been searching for this solution whole day, After quite a lot of googling . It has worked .

I have changed only one line in ks.cfg

**

# Use CDROM installation media
#cdrom
url --url="http://192.168.1.215/rhel"  // only added = and "" only 
# Use graphical install
graphical

**

Repeat of steps again for others:

Server Setup:
using http

webdir= /var/www/html

mkdir /webdir/rhel <br>
mount /dev/sr0 /webdir/rhel    //CDROM iso is mounted here <br>
chown -R root:root /website/rhel <br>
chmod 755 /webdir/ks.cfg<br>

Client:

Press Esc:
boot: linux ks=http://192.168.1.215/ks.cfg

It worked perfect.

2
  • .....well done! – Sum1sAdmin Apr 19 '16 at 9:24
  • Will this still work if your server hosting the ISO images is behind a proxy but your client is on the same network? I have a similar set up but my installation keeps failing because of "Installation source not found" – jonathon zayas Apr 23 '20 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.