2

I have an ESXi 5.1 host server with a Server 2012 VM server which I am monitoring remotely that hosts the email application Domino. I was using a third party VM backup software called Iperius which I initially liked. However, I noticed that since I got the software 2 months ago, it was not deleting the snapshots after it was done backing up the VM. This is my fault for not checking if the snapshots were being deleted.

The VM now has 13 embedded snapshots, so last night at 7pm, I clicked on Delete all Snapshots thinking the process would take anywhere from 4 to 8 hours like it usually does. However, it's been 14 hours and the process is seemingly stuck at 25%.

I ran a command that refreshes all of the vmdk files of the VM every 2 seconds, and they don't seem to be changing anymore. This makes me think the process is definitely stuck.

Also, the VM's CPU utilization is at 100%, and everything is much slower than usual. I know this is normal due to the sheer amount of read/write operations going on during the consolidation, but you can imagine how worried I am how badly this is affecting email performance for my client.

My question is, is there a way I can cancel the Snapshot Removal process without shutting of the VM, or should I just wait it out?

EDIT: Seems like I was wrong in that the process was stuck. I ran a different command that also updates the timestamp, and that is being updated. I guess the process is working, it's just terribly slow.

  • 13 Snapshots is realy a lot... VMware recommends 2-3 in a row, not older than 72 hours. All changes that were made on the machine since the first snapshot in the row have to be merged into the main vmdk file. Even when i forget to remove a snapshot after a week on a highly used machine, this can take time. – Tobias Apr 18 '16 at 14:55
  • I know... I was pretty upset when I realized Iperius doesn't delete snapshots after it's done backing up the VM. I was surprised it didn't since I was using GhettoVCB before this and that free solution did. I guess I shouldn't worry anymore and just let it run then. – Carlo71 Apr 18 '16 at 15:31
2

At 100% CPU on the VM, the hypervisor is going to have a devil of a time writing those snapshots in. You can see all the snapshots by going to the datastore and looking for all snapshots:

cd /vmfs/volumes/

then run

ls -alR | grep -I *.*delta | less

This will display all snapshots in each VM. You could go into the specific VM's directory to see just the snapshots in it. Hopefully, the number of snapshots will be decreasing over time.

One thing that might help - if you have control over the VM, think about powering it off from within the OS. This would then make the removal a simple file operation for the hypervisor.

  • The command I ran was similar. It displays all of the files in the VM folder and refreshes every 2 seconds displaying the size and timestamp of each file. The timestamp is being updated regularly, so the consolidation is working. It's just slow. I'll try shutting off the VM during non-business hours. Thanks for that tip. – Carlo71 Apr 18 '16 at 15:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.