2

I have a test setup containing:

  • 3 AD domain controllers (set up to replicate between them), all running Samba 4.3 on Univention Corporate Server 4.1
  • 1 Windows 7 SP1 client joined to the domain
  • 1 OmniOS r151018 file server running napp-it 16.02f joined to the domain with SMB/CIFS shares set up for some domain test users

The domain works as I would expect it, Windows login works, file server access works, DNS as well as direct IP connections work, even failover when shutting down one DC works.

The only thing that does not work is that I cannot see the OmniOS machine in the network browser/network neighborhood on the Windows 7 machine. I can find it in "Search Active Directory" when searching for all computers, and also connect to it using \\hostname (or IP) without problems or delay. It just does not seem to advertise itself properly. The 3 other servers and the Windows machine itself are there as one would expect and only vanish if the machines are powered down.

When searching for solutions I've found the suggestion to set the smb property system_comment, but it does not seem to do anything, even after a reboot.

On a side note, I also noticed that with the update to OmniOS r151016 and r151018 the usual direct discovery in Workgroup mode did not work anymore in comparison to r151012 (access is only possible by IP). This may or may not be related to my problem, I could not find any more detailed info aside from "multiple changes in SMB support" for the illumos releases that were incorporated into those OmniOS versions.

What may be the cause of this problem/inconvenience and how could I fix it? As a workaround, direct mapping of network drives would work, but this may become problematic if number of shares increases.

2

I have found the solution on another forum, answered just yesterday by the author of napp-it, gea.

Relevant excerpt:

I also found that OmniOS 151018 is not listed on a Windows machine under "network" even with a Windows server as Master Browser. You can enable Browsing when you set the smbshare property netbios_enable=true (napp-it menu Services > SMB > properties)

I've set the option over SSH with the command sharectl set -p netbios_enable=true smb, followed by a reboot of client and server and now it works flawlessly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.