I have a firewalled server to send data to over ssh on public network, but the SSH port is not the default 22. How do I configure the port to znapzendzetup?

For mbuffer setting the port is not an issue, but if the communication is unencrypted, I do not feel comfortable sending data over it.

  • it's not clear, to define a port in the client use the -P flag, to make the daemon listen on a non standard port edit it's config file. I don't know what the rest of your question means – Sum1sAdmin Apr 20 '16 at 12:28
  • The rest of my question refers to the ability to define a port when using mbuffer, but not when using ssh. I'll check on the -P flag for client, but I would just like the "zetup" to finish and successfully connect to the host. – Sampsa Suoninen Apr 20 '16 at 17:38
up vote 2 down vote accepted

To have special configuration for a particular connection, just create a Host section in your ~/.ssh/config file and do whatever magic you see fit. Make sure you use the .ssh/config of the user you are running your znapzend under ...

  • This should solve my issue. Is there any reason not to have it as a command line parameter similar to e.g. scp? – Sampsa Suoninen Apr 26 '16 at 9:46
  • the complexity of all possible ssh configurations is best covered by adding an appropriate entry to the .ssh/config file ... there would be no end to the options we would have to add. – Tobi Oetiker Apr 26 '16 at 12:17

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.