0

I have Shibboleth SP 2.5 with Apache 2.4 in front of Domino 9.0.1 server on Windows server 2008 R2.

This is the beginning of the incoming SAML message from Shibboleth SP debug log:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>

And here is an attribute value from the same log:

<saml:AttributeValue>Mäkelä Test</saml:AttributeValue>

Attributes are passed as HTTP headers to Domino. In Domino form I do @GetHTTPHeader("cn") to get that attribute value and I get

Mäkelä Test

In Shibboleth SP configuration I haven't set character set anywhere and I believe it should be always UTF-8.

My Apache proxy configuration looks like this:

ServerName my.test.fi:8443
UseCanonicalName On
ProxyPass / http://my.test.fi/

I have tried these:

ProxyHTMLMeta On
RequestHeader unset Accept-Encoding
AddDefaultCharset utf-8
CharsetSourceEnc  UTF-8
CharsetDefault    UTF-8

In domino Web Site document I have "Use UTF-8 for output" set to "Yes" and form character set is set to UTF-8. Domino response headers include this:

Content-Type:text/html; charset=UTF-8

For me it looks like the characters are already messed up when the arrive from Shibbolet SP/Apache to Domino. Any ideas how to fix this?

0

The solution is to use an XPage in Domino. This Server Side Javascript (SSJS) code returns scandinavian characters correctly:

facesContext.getExternalContext().getRequestHeaderMap().get("cn");

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.