I am trying to cluster 3 servers to then mount an NSS. I have all 3 configured and ready to roll. The only problem is none of them are apart of any cluster. When I run the: "cluster join" command I get the following:

Now a member of
This node is not a member of a cluster

I'm very green to clustering so I don't know exactly what to look for in this case. There is an edirectory object that is labeled "cluster" and it has all 3 servers listed underneath the object.

I have NCS installed and I am assuming configured properly. I have looked in the HA section of yast and insured that all 3 servers are a part of "cluster". iManager throws this error when I try to run cluster manager:

File Protocol error occurred: cannot open the NCS version file on the selected cluster. The Cluster software may not currently be running on this server.

It is all sles oes sp2. Not updated (for authentication reasons).

Any amount of help is greatly appreciated.

2 Answers 2


I Know its annoying when people say "have you looked at the documentation" but Novell do have a lot of resources on the support site...

If you go in to yast2 and use

OES Enterprise Server > OES Install and Configuration...

Once run it shows the parts that are configured etc...does it report NCS as configured?

Novell Doc Link

Hope this helps or gets you started in the right direction

I forgot to mention that iManager will throw back issues with cluster if it can not connect etc so you need to look at the cluster from the server level first in my opinion...

see you error comes with tickets like iManager Cluster which could be confusing

  • Yes, OES is reporting it being installed properly. And I know Novell has a ton of great resources out there, the only problem is they are almost ALL how-to's and almost no resolving problems. I followed a "how to" and they just assume that it will always work properly :( I still get this error: <code> File Protocol error occurred: cannot open the NCS version file on the selected cluster. The Cluster software may not currently be running on this server.</code>
    – lilott8
    Oct 22, 2009 at 14:29
  • yea I know, I dont like pointing ppl to docs as its not a nice answer...I will have another look when im back at work tomorrow...I have access to a 2 node cluster there
    – Rodent43
    Oct 22, 2009 at 20:18
  • I tried playing with the pam.d/openwbem file and made the necessary changes, but nothing helped. Still receive the above problem.
    – lilott8
    Oct 23, 2009 at 20:41

Your second error is correct, as it won't work until the cluster services are up and running. Which is where your first error comes in. I've seen the problem you mention, but I no longer have any OES1 servers any more and they moved things around with OES2. So I may get file locations wrong.

The clustering on OES1 wasn't terribly good. OES2 SP1 managed to deal with a lot of the problems, but you're not at that version. I've seen this specific problem occur when I was trying to migrate a cluster from NetWare to OES. The OES clustering tools didn't correctly handle the case of my cluster object. They stored the object as the lowercase word of my object, when it exists as an uppercase word in eDir, and that was enough to generate that "Is now a member of " message.

I don't remember if the OES1 clustering uses config files somewhere, or if all the data is stored on the cluster partition where you can't get at it.

  • I have activation keys for SP2. I will be reconstructing this test architecture with SP2 and hopefully that will not turn into a cluster....
    – lilott8
    Oct 23, 2009 at 20:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .