I have a Windows 2003 virtual machine which I use for website testing. I've just installed Windows 7 and am using the new version VPC (not xp mode).

When I try to copy a file - I need to copy some big databases across - I get a file copy speed of about 20k per sec. Copying from one PC to another on the real network transfers files at 13mb per second. Any ideas what may be causing this? I've turned off differential network compression on win 7.

The Virtual HD is on a seperate physical drive to the OS. Running Windows 7 64 bit on a dual xeon with 16gb ram and 10,000 rpm drives. Tried installing VPC 2007 but windows blocks it running saying its not compatable.

Many thanks for any ideas.

  • Solved (kind of). First I tried zipping the files and writing them to DVD. They copied fast but then I found that whilest the zip files were 50% smaller than with vista I could not open them. Finally I installed integration features and enabled a host drive to be seen from within virtual pc. The files are now copying at full speed. – Shigg Oct 22 '09 at 14:58
  • Spoke too soon. VPC seemed to hang and be generally slow regarding the network. It has proved so difficult that I'm simply shifting to VirtualBox. Hopefully this will perform better. – Shigg Oct 22 '09 at 16:06
  • Possible duplicate: Troubleshooting a Slow Network. – 87cd25770a Dec 27 '11 at 16:18

I had the same problem and the solution was to add a registry entry on the host machine:



add a DWORD entry with name DisableTaskOffload and a value of 1

This is also described in a Microsoft KB article. Although it applies to Virtual Server 2005, it also seems to be a solution for VPC 7.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy