6

I keep getting the following warning whenever I try to open a share from my DFS. warning msg

How can I configure Windows (10 in this case) to trust anything under the root of my DFS via GP?

It seems odd that it wouldn't do so automatically.

2

While the related SuperUser question has many solutions for this, they are mostly from the user's perspective: even the solution related to group policy uses Local Group Policy Editor and is far behind the accepted solution. Therefore, I'll just add a quick answer on how to do this for the whole network.

Create a GPO and enable three settings. Related descriptions and values explained in citations.

Both Computer Configuration and User Configuration has these:

  • Policies \ Administrative Templates \ Windows Components \ Internet Explorer

    • Internet Control Panel

      • Security Page
      • Intranet Zone Template > Enabled > Low

        This template policy setting allows you to configure policy settings in this zone consistent with a selected security level, for example, Low, Medium Low, Medium, or High.

        If you enable this template policy setting and select a security level, all values for individual settings in the zone will be overwritten by the standard template defaults.

      • Site to Zone Assignment List > Enabled > Show...

        • Valuename = yourserver

          A host for an intranet site, or a fully qualified domain name for other sites. The valuename may also include a specific protocol. For example, if you enter http://www.contoso.com as the valuename, other protocols are not affected. If you enter just www.contoso.com, then all protocols are affected for that site, including http, https, ftp, and so on. The site may also be expressed as an IP address (e.g., 127.0.0.1) or range (e.g., 127.0.0.1-10).

        • Value = 1 (Intranet zone)

      • Intranet Zone

        • Show security warning for potentially unsafe files > Enabled > Enable

          If you enable this policy setting and set the drop-down box to Enable, these files open without a security warning. If you set the drop-down box to Prompt, a security warning appears before the files open.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.