0

I'm trying to use a wireless USB key on a RHEL7 NUC. The adapter shows up in 'ifconfig':

eno1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.21  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::baae:edff:fe7d:ce5a  prefixlen 64  scopeid 0x20<link>
        ether b8:ae:ed:7d:ce:5a  txqueuelen 1000  (Ethernet)
...

enp0s20f0u3: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet6 fe80::214:d1ff:fed8:cc0f  prefixlen 64  scopeid 0x20<link>
        ether 00:14:d1:d8:cc:0f  txqueuelen 1000  (Ethernet)
...

but there is no wireless configuration options available in NetworkManager, so I'm not able to select an SSID/wpa2-password and so forth.

I found a thread that discussed a similar issue for centos. Following advice there, it appeared that I did not have the kernel module loaded for the wireless adapter:

# lspci -nn | grep -i net

00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection I219-V [8086:1570] (rev 21)
01:00.0 Network controller [0280]: Intel Corporation Wireless 8260 [8086:24f3] (rev 3a)

# grep -i 8086 /lib/modules/*/modules.alias | grep -i 24f3 | tee -a q
alias pci:v00008086d000024F3sv*sd00000010bc*sc*i* iwlwifi

# grep -i 8086 /lib/modules/*/modules.alias | grep -i 1570
alias pci:v00008086d00001570sv*sd*bc*sc*i* e1000e

# lsmod | grep wifi
# (NOTHING)

# modprobe iwlwifi
# lsmod | grep wifi
iwlwifi               112501  0 
cfg80211              514740  1 iwlwifi

However after following the advice in that thread for restarting the NetworkManager:

# service network stop
# service wpa_supplicant stop
# chkconfig --level 12345 network off
# chkconfig --level 12345 wpa_supplicant off
# chkconfig --level 2345 NetworkManager on
# service NetworkManager restart

there are no still no wireless configuration options showing in NetworkManager. I do have the NetworkManager-wifi package installed:

# rpm -qa | grep NetworkM
NetworkManager-config-server-1.0.0-16.git20150121.b4ea599c.el7_1.x86_64
NetworkManager-libreswan-0.9.8.0-5.el7.x86_64
NetworkManager-libnm-1.0.0-16.git20150121.b4ea599c.el7_1.x86_64
NetworkManager-glib-1.0.0-16.git20150121.b4ea599c.el7_1.x86_64
NetworkManager-wifi-1.0.0-16.git20150121.b4ea599c.el7_1.x86_64
NetworkManager-team-1.0.0-16.git20150121.b4ea599c.el7_1.x86_64
NetworkManager-openvpn-0.9.8.2-4.el7.1.x86_64
NetworkManager-openvpn-gnome-0.9.8.2-4.el7.1.x86_64
NetworkManager-tui-1.0.0-16.git20150121.b4ea599c.el7_1.x86_64
NetworkManager-1.0.0-16.git20150121.b4ea599c.el7_1.x86_60

What else do I need to do to make the wifi adapter available to NetworkManager. Or, perhaps simpler, how can I configure the wireless adapter on the command line?

  • Why does your server need wireless connectivity? – EEAA Apr 24 '16 at 3:01
  • It's temporary. I need to fish some wires into the room it will live. – Peeter Joot Apr 24 '16 at 3:18
0

It turns out that a newer than 3.10 kernel as well as updated firmware was required.

  • If you were able to get it working with a newer kernel, you should open a case with Red Hat so that they can fix the problem. – Michael Hampton Apr 26 '16 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.