I have II5 sitting on an old Windows 2000 Professional box. It has an FTP site there that allows me to access files. It works great, no problem at all.

However, now I need to setup a virtual directory that points to a share on another computer on the network (running Windows XP Tablet Edition). The share requires a user name and password. The network is a simple workgroup (i don't have any domains or any of that).

What is the correct procedure for that? I've tried setting a share via UNC and typing in the UserID/Password when asked. But when I finished, the virtual machine showed up as an error in the IIS Manager and couldn't access it.

I mapped the share onto a drive and then tried to setup a virtual directory with this drive. Same result.

Is there something simple I am missing? Would upgrading any part of the picture help at all?


Have you made sure file sharing is enabled, and not blocked by a software firewall on the Tablet?

Are you able to connect to the tablet from the FTP server using the UNC path (Start/Run)?

  • File sharing is enabled. I can connect to the share with the UNC via Start/Run (after entering UserID/Password). – AngryHacker Oct 23 '09 at 5:06

Remember that IIS probably does not run as the current user, and therefore it does not share your permissions.

Whatever network share you are using must be setup in such a way that the account IIS is using has access to it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.