1

I am trying to understand what causes the error code 1219 (multiple connections to server by same user).

The background of my question, we are currently installing a machine at a customer, where our service technician tried to connect with the host server. This caused issues, so I asked her to make the connection with net use, which gave the error code 1219.

As I saw that before, I remembered the sort of work-around, by using the IP address instead of the server name.

Now I was about to email the person responsible for their host environment that this issue was at hand, and ask them if they could help with a proper solution. Before I send that email, I wanted to reproduce the issue on my laptop, but I can't.

What I tried to do, is map another drive letter to a shared folder from my laptop, which I thought would give the same error, but my laptop allows me to make more than one network drive mapping to the same server.

net use:

C:\Users\bp>net use
New connections will be remembered.


Status       Local     Remote                    Network

----------------------------------------------------------------------------
OK           O:        \\***-hka-fs01\data       Microsoft Windows Network
OK           W:        \\***-hka-fs01\data\machine
                                                Microsoft Windows Network
OK           Y:        \\***-hka-fs01\data\machine\300
                                                Microsoft Windows Network
OK           Z:        \\***-hka-fs01.iai.nl\data
                                                Microsoft Windows Network
The command completed successfully.

Who can explain me a bit more about the background of the error code 1219 when using net use? Why am I allowed to make multiple connections, and when would it indeed result in the expected error code 1219?

3

The error 1219 says that you cannot open multiple sessions to a server, not connections. The number of connections is nearly unlimited by default (65532)

A session is a successfully authenticated combination of username/password from user(session) to a server, independently from the host (or the ressource you want to use, eg. network mapping, rpc, printer share or whatever). You can only open up two different (network-)sessions in one (user-)session. And always remember, yout local (and saved) credentials are sent to the remote server and if those successfully authenticate, this is session #1.

For example:

  • UserA connects to SERVER as "john", because he is logged on as "john" on his local machine
  • UserA connects to SERVER as "walker", because he needs to be "walker". he is using "net use \server /USER:walker"

In this case, the two sessions are used. 'Net use' will give you 1219 for any new connections.

The old NT trick using different server names (SERVER, SERVER.DOMA.IN, 192.168.0.1) to get up to six different sessions will no longer work, depending on your configuration.

To cean up your session connection credentials

  1. net use \\SERVER /delete
  2. Clear the Credentials Cache (from the Control Panel), more on theat here: https://security.stackexchange.com/questions/15574/how-do-i-clear-cached-credentials-from-my-windows-profile
  • thanks for the explanation. So what would happen if (from the same PC) I make one netuse connection without using credentials (thus use the credentials of the current user, say, "user1") and make a new connection where I do supply the username password, but with the exact same username as the local logged in user ("user1")? What I understand from your answer, is that the error would be given when two different users try to connect, but the error message states that 1 user can not create multiple session, right? – bas May 2 '16 at 8:32
  • Windows asumes a secondary session, if you supply username+password. Just like apps where you can chose between 'Windows Authentication" or Username+Password. There is no "use windows auth but with other credentials" option. – bjoster May 2 '16 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.