I have a config file and have a site up and running. But there is an issue if we go to the non-SSL page then also it redirects back to https. I have a site in Magento and it has base URL as http://www.cabletiesupply.com/ and base secure URL as https://www.cabletiesupply.com/ . Now I have not forced the admin to use SSL but then also it uses https:// which should not be the case. It should work normally as http:// . Which it is not. There is no issue in magento configuration.

I have created a gist of Nginx Config https://gist.github.com/bhargavmehta/4280a5a77b48236da82db2ee52fdc7d2

I am making a mistake in the configuration. Can anyone guide me in this?

Thank you

up vote 0 down vote accepted

remove the SSL config from nginx and enable it in 'magento' https://www.siteground.com/tutorials/magento/magento_ssl.htm

  • Can you suggest changes in nginx? – Bhargav Mehta Apr 27 '16 at 13:42

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.