0

We are running Exchange 2010 on SBS 2011. About a year ago, I renewed the certificate for the mail server, however, ever since that time, we receive certificate errors on OWA, and internally, we cannot create out of office messages (says the server is unavailable). I also now have a client running Outlook 2016 who cannot connect at all to the server. After much research, I think I have resolved that the certificate name doesn't match the exchange mail server name. I thought I renewed exactly what we had before, but apparently not. As an example, our mail server is actually: mail.mydomain.com, but the CN on the certificate is: remote.mydomain.com. Note that to connect to OWA, we use: https://remote.mydomain.com. The cert was done through godaddy. Our DNS is through Wordpress. Any advice for how to fix this....or am I stuck purchasing a new cert for mail.mydomain.com?

  • Honestly, you can get a certificate though Namecheap (from Comodo) for like $30.00 (or less). I'd suggest getting a new one as the easiest solution. - namecheap.com/security/ssl-certificates/domain-validation.aspx – joeqwerty Apr 28 '16 at 19:12
  • What Joe said, basically you'll need a new cert. Next time you might want to get a wildcard cert or one with both common names. If you're feeling really cheap you could also just reconfig to use remote.yourdomain.com to access the mail server. :) – Dylan Knoll Apr 28 '16 at 20:31
0

SBS wants to use remote.example.com for everything - and I would suggest that is what you use. If you have configured the server to use mail.example.com then you have two options.

  1. Run the configuration wizards in the SBS console to change the name to mail.example.com and get the SSL certificate reissued.
  2. Run the configuration wizards in the SBS console which will set Exchange etc to use remote.example.com. The Outlook clients will then be updated via Autodiscover internally. Mobile clients will need to be corrected. Externally if you have Autodiscover DNS records in place then that allow external machines to update.

It is key that you use the wizards to configure the server rather than the manual way for all functionality to work within SBS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.