0

Default VLAN: 10.36.0.0/24 New VLAN : 10.36.8.0/24 DHCP server : 10.36.0.17

I can see the DHCP offer packets making it back to my VLAN ip address namely 10.36.8.31 (from dhcp server message log)

Apr 28 15:33:13 dhcpd: DHCPOFFER on 10.36.8.129 to via 10.36.8.31

However the dhcp offer never makes it back to my machine connected to the new vlan(verified with wireshark as well)

The switch is HP Layer 3 Procurve

Running-Config(some details redacted)

Running configuration:

*; J9588A Configuration Editor; Created on release #KA.15.17.0008



*module 1 type j9588y

 module 2 type j9588x

-fault-finder broadcast-storm sensitivity high

fault-finder bad-driver sensitivity high

fault-finder bad-transceiver sensitivity high

fault-finder bad-cable sensitivity high

fault-finder too-long-cable sensitivity high

fault-finder over-bandwidth sensitivity high

fault-finder loss-of-link sensitivity high

fault-finder duplex-mismatch-hdx sensitivity high

fault-finder duplex-mismatch-fdx sensitivity high

fault-finder link-flap sensitivity high

jumbo ip-mtu 9000

power-over-ethernet redundancy n+1

qos tcp-port ipv4 22 priority 7

qos tcp-port ipv4 80 priority 1

qos tcp-port ipv4 443 priority 0

qos type-of-service diff-services

timesync sntp

sntp broadcast

sntp server priority 1 10.36.0.17

sntp server priority 2 10.36.0.18

no telnet-server

time daylight-time-rule western-europe

no web-management

web-management ssl

ip default-gateway 10.36.0.1

ip dns server-address priority 1 10.36.0.17

ip dns server-address priority 2 10.36.0.17

no ip ssh cipher aes128-cbc

no ip ssh cipher 3des-cbc

no ip ssh cipher aes192-cbc

no ip ssh cipher aes256-cbc

no ip ssh mac hmac-md5

no ip ssh mac hmac-sha1-96

no ip ssh mac hmac-md5-96

ip route 10.36.8.0 255.255.255.0 10.36.8.1

ip routing

snmp-server community "public" unrestricted

tls application web-ssl lowest-version tls1.2

tls application openflow lowest-version tls1.2

tls application syslog lowest-version tls1.2

tls application tr69 lowest-version tls1.2

aaa authentication ssh login public-key

oobm

   ip address 10.36.0.35 255.255.255.0

   exit

router rip

redistribute connected

   exit

vlan 1

   name "DEFAULT_VLAN"

   no untagged 20-21

   untagged 1-19,22-52

   ip address 10.36.0.31 255.255.255.0

   ip helper-address 10.36.0.17

   ip igmp

   exit

vlan 8

   name "WiredUsers"

   untagged 20

   ip address 10.36.8.31 255.255.255.0

   ip helper-address 10.36.0.17

   ip igmp

   exit

spanning-tree

Any suggestions as to why the DHCP offer cant hop from 10.36.8.31 to my machine on same subnet?

  • 1
    You're using RFC 1918 ip addresses. They're not relevant to anyone but you. We can't hack your network knowing your RFC 1918 ip address range. Stop obfuscating them in your question. Nobody can make sense of that. – joeqwerty Apr 28 '16 at 19:56
  • Apologies, edited. Clearly I'm new to this network administration thing – frodolicious Apr 28 '16 at 20:18
  • Thanks much. Now my brain can parse it. I don't do much with switching/routing but I see this statement: ip route 10.36.8.0 255.255.255.0 10.36.8.1, but I see this ip address for VLAN 8: ip address 10.36.8.31 255.255.255.0. That doesn't seem right to me. Shouldn't the route be 10.36.8.0 255.255.255.0 10.36.8.31? – joeqwerty Apr 28 '16 at 20:57
  • I tried that already while configuring a route but I get the error "10.36.8.31 can not be switch IP address and route gateway at the same time". – frodolicious Apr 28 '16 at 21:02
0

I'm thinking that you probably don't need to define an explicit route for the 10.36.8.0/24 network because it's a directly connected network. Try removing that routing statement and then look at the routing table and see if there's a route for 10.36.8.0 that shows as directly connected or similar. I'm not familiar with HP switches, so I'm basing this on my knowledge of Inter-VLAN routing with Cisco switches. Then see if your DHCP client gets a DHCP assigned ip address.

Here's the output from a Cisco 3560 switch. You'll see that I have no explicitly defined routing statements for my VLAN's, as they're all directly connected.

Switch#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/16 is subnetted, 4 subnets
C       10.1.0.0 is directly connected, Vlan10
C       10.2.0.0 is directly connected, Vlan20
C       10.3.0.0 is directly connected, Vlan30
C       10.4.0.0 is directly connected, Vlan40

Switch#sh run
Building configuration...

Current configuration : 1504 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
no spanning-tree vlan 1,10,20,30,40
!
!
!
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport access vlan 40
 switchport mode access
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 ip address 10.1.0.1 255.255.0.0
!
interface Vlan20
 ip address 10.2.0.1 255.255.0.0
!
interface Vlan30
 ip address 10.3.0.1 255.255.0.0
!
interface Vlan40
 ip address 10.4.0.1 255.255.0.0
!
ip classless
!
!
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


Switch#
  • done, still the same. The vlan does seem to be connected although I don't know if the output of my "show ip route" is analogous to yours, it probably is IP Route Entries Destination Gateway VLAN Type Sub-Type Metric Dist. ------------------ --------------- ---- --------- ---------- ---------- ----- 10.36.0.0/24 DEFAULT_VLAN 1 connected 1 0 10.36.8.0/24 WiredUsers 8 connected 1 0 – frodolicious Apr 28 '16 at 21:18
  • Is the DHCP client connected to a port in VLAN 8? – joeqwerty Apr 28 '16 at 21:35
  • yes, the only port in that vlan, port 20. – frodolicious Apr 28 '16 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.