1

I am migrating our public folders from Exchange 2010 to exchange online. I followed Microsoft's guide: https://technet.microsoft.com/en-CA/library/dn874017(v=exchg.150).aspx

The migration went well for all public folder except one. This is the error I get:

28/04/2016 20:52:19 [BN3PR11MB0225] Public folder could not be mail-enabled. The error is as follows: "No mail public folder was found in Active Directory with OnPremisesObjectId= I removed this part

28/04/2016 20:52:19 [BN3PR11MB0225] Stage: IncrementalSync. Percent complete: 95. 28/04/2016 20:52:19 [BN3PR11MB0225] Fatal error FailedToMailEnablePublicFoldersException has occurred.

I tried to mail-disable the PF (it did resolve other errors I had) - Error does not go away.

I ran the Sync-MailPublicFolders.ps1 - Error does not go away.

Has anyone ever had this error!?

Thank you very much!

1

Seems like you are on the right track. Microsoft has published a KB on this issue here: https://support.microsoft.com/en-us/kb/3050726

From the KB

Mail-disable all public folders that are mail-enabled in the NON_IPM_SUBTREE folder. For more information about how to mail-disable a public folder

To locate the system public folders, open the Exchange Management Console, go to Toolbox, open the Public Folder Management Console, and then expand System Public Folders. Mail-disable any public folder that has a mail icon next to it.

0

The above suggestion looks good.

"FailedToMailEnablePublicFoldersException has occurred”, it probably means that the public folders can’t be mail-enabled using the migration script. Please try manually mail enable the public folder first, then resume the migration batch and check if any improvement, check this thread to get in detailed: https://community.office365.com/en-us/f/158/t/410385

Hope this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.