2

Note: email addresses, domains, and ip addresses have been changed to protect the innocent

Current Error:

Apr 28 23:47:32 vps01 postfix/smtp[8012]: 2A03D6285EF9: to=<brian@somedomain.com>, relay=mail.somedomain.com[162.144.93.233]:25, delay=42, delays=0.01/0.02/21/21, dsn=5.0.0, status=bounced (host mail.somedomain.com[162.144.93.233] said: 550-Verification failed for <test@mydomain.org> 550-The mail server could not deliver mail to test@mydomain.org. The account or domain may not exist, they may be blacklisted, or missing the proper dns entries. 550 Sender verify failed (in reply to RCPT TO command))

I am trying to get email working for a client with several domains on a vps running Ubuntu Server and Apache2. Server has IspConfig 3 installed if it makes any difference to anybody.

I am able to receive and send emails to most of the domains that I have tried so far except one in particular. Others are probably failing that are unknown to me.

I was receiving an error 550 Access denied - Invalid HELO name (See RFC2821 4.1.1.1) but I have been able to fix that as far as I know by creating rDNS record and changing my hostname in postfix to my FQDN. This has proceeded to my current error.

I have followed the guide at https://www.howtoforge.com/hardening-postfix-for-ispconfig-3 to harden my postfix to prevent spam.

I have reviewed Postfix Sender Verification 550 and checked my MX records but it appears to me that everything is set correctly.

dig mydomain.org MX

; <<>> DiG 9.9.5-9ubuntu0.5-Ubuntu <<>> mydomain.org MX
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18363
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;mydomain.org.             IN      MX

;; ANSWER SECTION:
mydomain.org.      1199    IN      MX      10 55.55.55.55. (ip address changed for security purposes)

;; Query time: 44 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Thu Apr 28 23:54:59 CDT 2016
;; MSG SIZE  rcvd: 75

I have been using http://mxtoolbox.com/SuperTool.aspx?action=smtp%3amydomain.org&run=toolpage# to check for problems along the way as well, but the only insight it is giving me know appears to be longer connection and transaction time which I believe is due to configuring postscreen.

Full mail.log for time period during errors

Apr 29 00:24:44 vps01 postfix/smtpd[9021]: connect from localhost.localdomain[127.0.0.1]
Apr 29 00:24:44 vps01 postfix/smtpd[9021]: DA4326285EF9: client=localhost.localdomain[127.0.0.1]
Apr 29 00:24:44 vps01 postfix/cleanup[9013]: DA4326285EF9: message-id=<79da838b66dd1fd030bfe64355ca8d42@mydomain.org>
Apr 29 00:24:44 vps01 postfix/smtpd[9021]: disconnect from localhost.localdomain[127.0.0.1]
Apr 29 00:24:44 vps01 postfix/qmgr[7860]: DA4326285EF9: from=<test@mydomain.org>, size=1671, nrcpt=1 (queue active)
Apr 29 00:24:44 vps01 amavis[8496]: (08496-10) Passed CLEAN {RelayedOpenRelay}, <test@mydomain.org> -> <brian@somedomain.com>, Message-ID: <79da838b66dd1fd030bfe64355ca8d42@mydomain.org>, mail_id: aJjfGa_rtNVH, Hits: -0.101, size: 1145, queued_as: DA4326285EF9, dkim_sd=dkim:mydomain.org, 399 ms
Apr 29 00:24:44 vps01 postfix/smtp[9018]: 669CD6285BEA: to=<brian@somedomain.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.5, delays=0.08/0.02/0/0.4, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as DA4326285EF9)
Apr 29 00:24:44 vps01 postfix/qmgr[7860]: 669CD6285BEA: removed
Apr 29 00:25:01 vps01 postfix/postscreen[9069]: CONNECT from [::1]:44502 to [::1]:25
Apr 29 00:25:01 vps01 postfix/postscreen[9069]: WHITELISTED [::1]:44502
Apr 29 00:25:01 vps01 postfix/smtpd[9071]: connect from localhost[::1]
Apr 29 00:25:01 vps01 postfix/smtpd[9071]: lost connection after CONNECT from localhost[::1]
Apr 29 00:25:01 vps01 postfix/smtpd[9071]: disconnect from localhost[::1]
Apr 29 00:25:27 vps01 postfix/smtp[9022]: DA4326285EF9: to=<brian@somedomain.com>, relay=mail.somedomain.com[162.144.93.233]:25, delay=43, delays=0.01/0.01/22/21, dsn=5.0.0, status=bounced (host mail.somedomain.com[162.144.93.233] said: 550-Verification failed for <test@mydomain.org> 550-The mail server could not deliver mail to test@mydomain.org.  The account or domain may not exist, they may be blacklisted, or missing the proper dns entries. 550 Sender verify failed (in reply to RCPT TO command))
Apr 29 00:25:27 vps01 postfix/cleanup[9013]: D2C3E6285EFA: message-id=<20160429052527.D2C3E6285EFA@mn-vps-01.cbcmcalester.com>
Apr 29 00:25:27 vps01 postfix/qmgr[7860]: D2C3E6285EFA: from=<>, size=4219, nrcpt=1 (queue active)
Apr 29 00:25:27 vps01 postfix/bounce[9112]: DA4326285EF9: sender non-delivery notification: D2C3E6285EFA
Apr 29 00:25:27 vps01 postfix/qmgr[7860]: DA4326285EF9: removed
Apr 29 00:25:27 vps01 dovecot: lda(test@mydomain.org): sieve: msgid=<20160429052527.D2C3E6285EFA@mn-vps-01.cbcmcalester.com>: stored mail into mailbox 'INBOX'
Apr 29 00:25:27 vps01 postfix/pipe[9113]: D2C3E6285EFA: to=<test@mydomain.org>, relay=dovecot, delay=0.06, delays=0.01/0.02/0/0.03, dsn=2.0.0, status=sent (delivered via dovecot service)
Apr 29 00:25:27 vps01 postfix/qmgr[7860]: D2C3E6285EFA: removed
Apr 29 00:25:28 vps01 postfix/anvil[8945]: statistics: max connection rate 1/60s for (smtpd:64.20.227.137) at Apr 29 00:22:05
Apr 29 00:25:28 vps01 postfix/anvil[8945]: statistics: max connection count 1 for (smtpd:64.20.227.137) at Apr 29 00:22:05
Apr 29 00:25:28 vps01 postfix/anvil[8945]: statistics: max message rate 1/60s for (smtpd:64.20.227.137) at Apr 29 00:22:07
Apr 29 00:25:28 vps01 postfix/anvil[8945]: statistics: max cache size 1 at Apr 29 00:22:05

It appears that I did not receive the RCPT TO command to verify the user. I have researched online that trying to resolve this is a waste of time and should just tell the receiving domain to turn off verifying users but this is not an available option.

UPDATE

OK, I have made the DNS changes and new mx record host @ points to mail.mydomain.org. I have already created A record for mail to point to my ip address. I will wait for dns to propogate and try again.

  • 1
    You should not use ip address in the MX record - IN MX 10 63.142.252.80. – ALex_hha Apr 29 '16 at 14:52
3

You have a really strange setup

telnet mail.abcgreenbrier.org 25
Trying 63.142.252.80...
Connected to mail.abcgreenbrier.org.
Escape character is '^]'.
220 mn-vps-01.cbcmcalester.com ESMTP Postfix (Ubuntu)
helo localhost
250 mn-vps-01.cbcmcalester.com
mail from:<>
250 2.1.0 Ok
rcpt to:<test@abcgreenbrier.org>
450 4.2.0 <test@abcgreenbrier.org>: Recipient address rejected: Greylisted, see http://postgrey.schweikert.ch/help/abcgreenbrier.org.html

Why are you greylisting your own domain?

  • It was recommended to me to enable greylisting although I have never been fond of its operation. I installed postgrey and then edited main.cf and added check_policy_service inet:127.0.0.1:10023 to the end of smtpd_recipient_restrictions:. I am not sure how it should be setup correctly it is currently disabled. – amaster Apr 29 '16 at 19:30
  • 1
    @amaster507 Greylisting will definitely cause sender verify to fail. There's not much you can do about this. While greylisting is a fairly reasonable thing to do if you get lots of spam, sender verify never has been something you can do reliably. I'm a little surprised to hear that someone is still doing it. – Michael Hampton Apr 29 '16 at 23:52
  • After fixing my DNS issues as was commented to the question and disabling greylisting emails are being received and sent correctly. – amaster May 4 '16 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.