2

I've got a Windows 2012 Server VM that I've cloned from another VM.

I've done the following:

  • Right-Clicked on "This Computer" -> Properties -> Remote Settings and checked "Allowed Remote Connections to This PC"
  • Gone to "Windows Firewall with Advanced Security" -> "Inbound Rules" and made sure that all options for "Remote Desktop - User Mode" are allowed through the firewall.
  • Manually started all "Remote Desktop" related services just to see if it would do anything.
  • Validated that Remote Desktop is running on the default port of 3389 by looking at the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

Despite all of this I can't connect to this machine via Remote Desktop. All other network ports seem to work fine and traffic works two directions.

If I run:

netstat -a

I also don't see anything listening on port 3389. As a result it seems Remote Desktop isn't running despite all of what I've done.

1
  • What do you mean by can't connect? Is it timing out, is the client not accepting the certificate, invalid credentials? Did you run sysprep before cloning? – Brian Duke Apr 29 '16 at 20:05
3

The problem was due to the machine being cloned.

Remote Desktop has a certificate associated with it. That certificate has the machine name within it. If the machine name in the certificate does not match the current machine name, Remote Desktop will not run.

To solve this problem:

  1. Run the Certificate Manager ( certlm.msc ).
  2. Navigate to Remote Desktop -> Certificates
  3. Delete the Certificate. (You should see its for a different computer name)
  4. Reboot the Machine

A new certificate will be created on reboot and it should work.

1
  • I ran into a similar issue my self. it turned out to be a licenses issues. I had cloned a machine with a Terminal server feature enabled but had not applied a new key for that service. – Honk Nov 9 '17 at 19:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.