1

I have a PowerDNS 3.3 server installed on Ubuntu 14.04 (for testing).
It should be master only. No slave exists.

I keep on getting this error:

Received NOTIFY for mydomain.com from 82.91.23.176 but slave support is disabled in the configuration
Received unsuccessful notification report for 'mydomain.com' from 82.91.23.176:53, rcode: 4

82.91.23.176 (modified in this post) is the WAN IP of the PowerDNS server.

Here my pdns.conf

allow-axfr-ips=127.0.0.1
allow-recursion=127.0.0.1
config-dir=/etc/powerdns
daemon=yes
disable-axfr=no
guardian=yes
include-dir=/etc/powerdns/pdns.d
local-address=0.0.0.0
local-port=53
master=yes
module-dir=/usr/lib/powerdns
setgid=pdns
setuid=pdns
socket-dir=/var/run
version-string=powerdns
webserver=yes
webserver-address=192.168.178.33

To my understanding, slave=no is per default and no slave is allowed for axfr, so PowerDNS should not receive any notification at all.

Or what is this message about?

2

You have set master=yes which tells PowerDNS to send notifications. It does not check sent notifications against the allow-axfr-ips list because transfers might not come from the notified IPs.

If you want the NOTIFY to go away, set master=no.

7
  • Yes, that worked (thanks!), though I don't really understand it. Very hard to find basic PowerDNS FAQs/TOWTOs explaining basic mechanisms (while DNS basics are known). – geohei May 14 '16 at 18:33
  • Also ... (1.) PowerDNS seems to self-notify. Why is this? (2.) Self-notification can be disabled by prevent-self-notification. This seems to work. If master/slave configuration is used, master=yes must be set. Hence your suggestion would not work in this case. – geohei May 15 '16 at 18:01
  • I got a bit further. The point is that the master server notifies itself, which should be avoided. I need master enabled since I would like to install at least 1 slave server later on. So master=yes will be set, triggering again the mentions warnings. The bottom line is that I need to know how PowerDNS tries to avoid this self-notification. prevent-self-notification=yes doesn't do it! I could not find any documentation about this subject (Google), but quite a lot of postings around 2013 that it will be fixed. So ... how do the PowerDNS mechanisms work to avoid self-notification! – geohei May 22 '16 at 6:20
  • Avoiding self notification is hard in some network setups. You have not described yours so I cannot usefully comment. You could also decide to just ignore the messages! – Habbie May 22 '16 at 14:04
  • On a sidenote, I see you are trying to post to the PowerDNS pdns-users mailing list via Nabble. This no longer works, as clearly marked on Nabble. If you want to post to the mailing list, please subscribe to it and send an actual email. – Habbie May 22 '16 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.