I have been following this tutorial:

$ sudo systemctl start nagios
Failed to start nagios.service: Unit nagios.service failed to load: No such file or directory.

What is the cause of problem?

I have:

$ sudo /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

Nagios Core 4.0.8
Copyright (c) 2009-present Nagios Core Development Team and Community Contributors
Copyright (c) 1999-2009 Ethan Galstad
Last Modified: 08-12-2014
License: GPL

Website: http://www.nagios.org
Reading configuration data...
   Read main config file okay...
   Read object config files okay...

Running pre-flight check on configuration data...

Checking objects...
    Checked 8 services.
    Checked 1 hosts.
    Checked 1 host groups.
    Checked 0 service groups.
    Checked 1 contacts.
    Checked 1 contact groups.
    Checked 24 commands.
    Checked 5 time periods.
    Checked 0 host escalations.
    Checked 0 service escalations.
Checking for circular paths...
    Checked 1 hosts
    Checked 0 service dependencies
    Checked 0 host dependencies
    Checked 5 timeperiods
Checking global event handlers...
Checking obsessive compulsive processor commands...
Checking misc settings...

Total Warnings: 0
Total Errors:   0

Things look okay - No serious problems were detected during the pre-flight check

I created this file:

 sudo vi /etc/systemd/system/nagios.service

and added the following:



ExecStart=/usr/local/nagios/bin/nagios /usr/local/nagios/etc/nagios.cfg

Then the following:

   sudo systemctl enable /etc/systemd/system/nagios.service
   sudo systemctl  start nagios
   sudo systemctl  restart nagios
  • 1
    you should give yourself credit for answering your own question :D – Greg Gauthier Aug 10 '16 at 16:12
  • @GregGauthier users are not allowed to upvote their own answers! – Mona Jalal Aug 10 '16 at 18:55
  • 1
    no, but they are allowed to mark them as as the correct answer. You hadn't done that yet. Which was sort of what I was implying: I tried your answer, and it worked for me. Might as well mark it as the "correct" one :D – Greg Gauthier Aug 15 '16 at 9:56
  • You can also operate it with sudo service nagios <action> - (and configtest now I'm upgrading to nagios4 seems to work properly too - with v3 I used to have to do sudo /usr/sbin/nagios3 -v /etc/nagios3/nagios.cfg) – William Turrell Feb 2 '18 at 12:26

protected by Community Nov 3 '17 at 10:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.