2

I'm trying to install Web server role / iis to my dynamic Windows 2012 cloud server but keep getting the following errors:

If I have the following not installed and try to install web server / iis 8.0 it keeps telling me I have a restart pending. If I go to tools I can see iis manager and open it and navigate to local host however the role is not added to the server and on restarting it all disappears.

  • “Windows Process Activation Services"

If I install the above and try and install I get the following error code which google has not revealed much

  • 0x800f0922

I have so far tried the following - deleting the main folder on drive C: - tried installing via powershell and command promt - removing iis by running the following command "start /w pkgmgr.exe /uu:IIS-WebServerRole;WAS-WindowsActivationService" - I have also run the following command: dism /online /cleanup-image /restorehealth - I have cleared / deleted the updates to see if something was in corrupted. - I have also ran the .NET fix application.

Other roles still install on the system.

Has anyone got any ideas what else can try before I have to wipe the system which seems a bit over kill and a lot of work as this is a live production server.

Thanks in advance. J

0

Check the IIS and CBS (component based setup) logs, should yield more details on what failed.

IIS Logs: c:\windows\iisx.log (where 'x' is the version of IIS you're installing)
CBS Logs: c:\windows\logs\cbs

  • Thanks for this in the iis log I get the following errors : < WARNING! > Failed to detect if config redirection is enabled. result=0x80070032.Assuming config is not redirected and continuing and Ignoring acceptable LaunchCommand failure 0x80070002 – Hoube78 May 4 '16 at 15:49
  • Anything in the CBS logs? Searching for the LaunchCommand error suggests executing the pkgmgr command you've already tried. – Sloan Ozanne May 4 '16 at 16:00
  • I found this towards the end but not sure what to look for? 2016-05-04 17:21:21, Info CSI 00000124 [DIRSD OWNER WARNING] Directory [ml:520{260},l:38{19}]"\??\C:\inetpub\logs" is not owned but specifies SDDL in component Microsoft-Windows- – Hoube78 May 4 '16 at 16:39
  • Another part of the log the code its too long to upload as a comment: Startup: Retrying failed packages. 2016-05-04 17:22:11, Info CBS Startup: Processing complete. [HRESULT = 0x80004005 - E_FAIL – Hoube78 May 4 '16 at 16:41
  • Start by deleting c:\inetpub (subdirectories and all). Then dump the c:\windows\iisx.log. Trying to get to a clean slate. The go with: Dism /Online /Cleanup-Image /CheckHealth Dism /Online /Cleanup-Image /ScanHealth Dism /Online /Cleanup-Image /RestoreHealth Reboot and attempt to reinstall IIS. If that doesn't work, consider lobotomizing the box and starting over. – Sloan Ozanne May 4 '16 at 17:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.