5

Why can I not view/use/map a drive from a machine using its short hostname if the short hostname is proven resolvable by DNS?

I have a machine (the client in this example) running Windows Server 2008r2 Standard.

I cannot view, use, or map network drives from my fileserver onto this machines, using the short hostname.

I can do all that, eg net view myfileserver.example.com if I use the fully qualified domain name as shown, or if use the IP address.

I can ping the machine using the short name, and nslookup returns the proper IP address if I use the short name.

I could map a network drive on a machine in another domain using either the FQDN or the short name, eg: net use \\otherfileserver\IPC$ /u:"otherdomain\mylogin" "mypassword" /persistent:no

A real head scratcher (to me).

Note also that many other client machines are mapping network drives from the same fileserver.

EDIT: Ok, I awarded the bounty to Sum1sAdmin. I think he was on to something with the whole Browser thing. The problem is not DNS, no way no how it could be. Shortnames, longnames, skinny names, fat names, fully qualified names- they were all resolvable. It was NetBios (props to Noor Khaldi for being the first to bring it up, btw).

But it was Sum1sAdmin that pushed me to look at browsing in general. And because of that, I found that I had two Linux machines that were acting as the Masters for my domain. That was not good, because I have a mixed Linux/Windows environment and as it says in the smb.conf file: "Domain Master specifies Samba to be the Domain Master Browser...Don't use this if you already have a Windows NT domain controller doing this job..." which I do. In any event, I don't trust Samba to play well with Windows. If I can't call Microsoft Tech Support and say, "Yeah I have this browsing issue and by the way the master is a CentOS 5.3 machine running Samba," and they say, "Ok, cool!" then I'm not comfortable. I want my Windows-y things to live in Windows, and Linux be the client- only.

That said, I removed Samba's ability to be the domain master. This totally broke my browsing and made any net view command return an error 53, "The network path was not found." on all hosts for a while. Then after a while I got a new error instead: system error 6118, "The list of servers for this workgroup is not currently available." Waiting further, I suddenly started to see some machines. Using Scottie's handy dandy script (http://scottiestech.info/2009/02/14/how-to-determine-the-master-browser-in-a-windows-workgroup/), I then started to see machines and new Windows masters.

All that said, the original machine is still broken. And now, some 10 minutes later, my domain has again broke with system error 6118. If you check my conversation with Sum1sAdmin, you will see that my domain is kind of screwy. This is good, because now I know that the issue was never just random. If it's broke, and I know where it's broke, I can fix it. And right now NetBios is all kinds of broke because it was never set up correctly in the first place, which started with me figuring out that Linux was involved. (Which actually may not have caused a problem but regardless, I want to remove that wildcard from the environment and let Windows be Windows).

Anyway, thanks for all the responses. I'm going to keep futzing with this system until it works.

8
  • Can the 2008 R2 server not browse any other hosts by short host name, or does it just not work for the file server? May 11, 2016 at 17:04
  • Have you already checked the network discovery settings for the network profile? serverfault.com/questions/634982/… May 11, 2016 at 17:09
  • Are you getting any errors when you try and access the share by hostname? Are the "many other client machines" mapping network drives using hostname or FQDN?
    – Tim Aitken
    May 12, 2016 at 6:27
  • is the "Connection-specific DNS Suffix Search List" the same on all machines (ipconfig /all) and what is the tld of the domain you've chosen for internal use? .local or .dev May 17, 2016 at 23:01
  • It just does not work for the file server. It can browse other hosts. When I go to the Control Panel->Network and Sharing Center, and open the domain at the top, I see icons for a number of systems- including the fileserver. I can open any system I want except for the fileserver. "Windows cannot access ... Error code: 0x80070035 The network path was not found."
    – Mike S
    May 17, 2016 at 23:32

4 Answers 4

2
+50

I think this is pointing to your 'master computer browser' service on the emulated PDC - possibly it's stopped, you have proved that netbios over tcp is working, so we can rule that out - it's not DNS or domain suffix configuration on your interface, as 1) it works with FQDN 2) we don't want to use FQDN. So I would venture that 'Computer Browser Server' is where the issue is. It's possibly stopped as the result of an election process and is now running on different 'Master' a machine which thinks it's master and forces and election.

Browser Elections, Browser elections occur to select a new master browse server under the following circumstances: When a computer cannot locate a master browse server.

When a preferred master browse server comes online.

When a Windows-based domain controller starts.

When a back-up browse server cannot contact the master browse server to obtain updates to the browse list.

troubleshooting why the browser service was stopped is referenced in this common causes kb article https://support.microsoft.com/en-ie/kb/135404

what is this service?

Browser service or Computer Browser Service is a feature of Microsoft Windows to let users easily browse and locate shared resources in neighboring computers. This is done by aggregating the information in a single computer "Browse Master" (or "Master Browser").

If you have recently upgraded a straggling Windows server 2003 box then it's worth quoting: https://technet.microsoft.com/en-us/library/bb726965.aspx

Computer Browser Service Windows Server 2008 sets the startup state of the Computer Browser service to disabled by default for a new installation of Windows Server and when upgrading an existing server to Windows Server 2008. The Computer Browser service helps maintain an updated list of domains, workgroups, and server computers on the network and supplies this list to client computers upon request. For detailed information about Computer Browser service operation, see Appendix C - Computer Browser Service. The default startup state of the Computer Browser service on computers running Windows Server 2008 can cause problems for a domain controller in the primary domain controller flexible single master operations (PDC FSMO) role. For computer browsing, a computer in the PDC FSMO role centrally collects and distributes information about domains, workgroups, and computers for multi-subnet networks. If the computer in the PDC FSMO role is not running the Computer Browser service, computer browse lists across the network will contain only domains, workgroups, and computers on the local subnet. To prevent this problem, configure the startup type for the Computer Browser service for Automatic on the computer in the PDC FSMO role and then start Computer Browser service. You can do this from the Services snap-in or at an elevated command prompt with the following commands: sc config browser start= auto sc start browser Because the Computer Browser service relies on file and printer sharing, you will also need to turn on File and Printer Sharing in the Network and Sharing Center. Alternatively, move the PDC FSMO role to another domain controller that has the Computer Browser service started and configured for automatic startup and File and Printer Sharing turned on in the Network and Sharing Center. Additionally, if the only server computer on a subnet is running Windows Server 2008, client computers will become the local browse server on the subnets. As client computers are started and are shut down, the role of the local browse server will pass from one client computer to another, possibly resulting in an inconsistent display of domains, workgroups, and computers. To prevent this problem, on the computer running Windows Server 2008, turn on file and printer sharing, configure the startup type for the Computer Browser service for Automatic, and then start the Computer Browser service.

11
  • Does this answer apply if other computers in the same domain and on the same LAN segment are working properly? Also, note that when I go to my network control panel and open my domain, I can browse all the computers there- except this one. Furthermore, when I right click on the problem machine, I can choose "Connect with Remote Desktop Connection" and it works.
    – Mike S
    May 17, 2016 at 23:52
  • Yes I don't think you have connectivity issues or DNS, I think it's the computer browser service for that segment. Either it's not maintains an updated list of hosts, the host cannot update the browser service (UDP) or anonymous access has been removed from $IPC share. Can you confirm your domain function level in the question?
    – Sum1sAdmin
    May 18, 2016 at 8:48
  • @MikeS - on the affected host, you should check the status of the service Function Discovery Resource Publication Publishes this computer and resources attached to this computer so they can be discovered over the network. If this service is stopped, network resources will no longer be published and they will not be discovered by other computers on the network.
    – Sum1sAdmin
    May 18, 2016 at 9:58
  • @Sum1sAdmin- I have checked, and FDRP was not started. I have started it. There is no change. I don't know how it would affect the situation, though, because the machine is trying to get a resource which is outside of it. So I don't have a problem with this machine being discovered by other computers. I have a problem with this computer utilizing a resource from another computer, which is actually discovered.
    – Mike S
    May 18, 2016 at 13:27
  • I'm not sure what it means to "confirm your domain function level in question"? Other machines on the same LAN segment, in the same domain, can browse to the fileserver by shortname. This machine can see the fileserver's shortname but cannot open it. This machine can browse any other computer by shortname.
    – Mike S
    May 18, 2016 at 13:28
6

As Noor Khaldi says it could be a problem related with NetBios or the TCP Helper of NetBios.

The destination computer and the client one are in the same local domain? It could be a problem related with the DNS suffix.

Run a ipconfig /all and look for the DNS Suffix Search List at the top of the results and look for the Connection-specific DNS Suffix of the network interfaces. The first one should have the suffix for the domain you're in, and the custom suffix of each NIC should be empty or with the same info as the global one.

If you're in a hurry you can set this registry hack to allow the use of aliases when contacting with shares:

Edit the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters and add a value DisableStrictNameChecking of type DWORD and set it to 1.

9
  • The machines share the same local domain, so I don't think that's it.
    – Mike S
    May 17, 2016 at 23:02
  • ...And the suffix is found in the global list in any event.
    – Mike S
    May 17, 2016 at 23:19
  • Did you tried the registry hack ?
    – NetVicious
    May 18, 2016 at 10:20
  • I did it. Nothing changed. I don't expect it to, because this machine can access other hosts via shortname. Also my DNS Suffix Search List looks fine. Besides, the fileserver is pingable by shortname. I don't think DNS is the culprit, as I said in my question "the short hostname is proven resolvable by DNS"
    – Mike S
    May 18, 2016 at 13:34
  • You said the client it's a W2008 R2, but which SO has the server ? In that case the problem obviously it's Netbios or SMB (LanMan). Microsoft added some months ago more strict checkings to SMB communications. sernet.de/en/news/news-detail/detail/…
    – NetVicious
    May 18, 2016 at 14:57
1

It all depends on the name resolution strategy you have in there, from your description, it seems that NetBIOS name resolution (which is used for short names) is failing to look up the IP address of the server you're looking for.

"Ping" is going to use the FQDN name so you're not supposed to use it while looking for short names, instead use "NBTStat" to test.

  1. Check if NetBIOS is enabled on both the computers you're working on.
  2. Use the NBTStat command to see if you're able to resolve the hostname.
  3. Add the destination IP/Name to the Hosts file if name resolution fails. or check why you're unable to connect if it's resolving correctly.

For further reading: https://blogs.msdn.microsoft.com/nitinsingh/2013/06/24/dilemma-of-name-resolution-process-with-ping-vs-nslookup/

2
  • Thanks for your reply. nbtstat successfully shows a Node IpAddress when I give it my host hostname. However, I am still not able to refer to the machine using a path of the shortname when I am trying to map a drive.
    – Mike S
    May 9, 2016 at 18:53
  • ...and I note (as mentioned elsewhere) that I can access other hosts reliably, using the shortname. The problem seems to be related to this one fileserver, from this single host.
    – Mike S
    May 18, 2016 at 0:04
0

Is the problem server on the EXACT same network as the other servers. For instance 192.168.1.x/24 and 192.168.2.x/24 are different networks. Without additional infrastructure namely a WINS server you cannot resolve short (Netbios) names across networks. In all of your examples you cite FQDN's as working. DNS is designed to span networks and will work as expected. Can you confirm that both of the servers in question are on the SAME IP network/subnet?

3
  • Problem machine: IP 10.44.101.101, mask 255.255.255.0, gateway 10.44.101.2. OK machine: IP 10.44.101.40, mask 255.255.255.0, gateway 10.44.101.2. Fileserver that we are trying to reach via shortname: IP 10.44.101.102, mask 255.255.255.0, gateway 10.44.101.2
    – Mike S
    May 17, 2016 at 23:59
  • Furthermore, I can resolve short (Netbios) names- there are 12 machines I can browse. Just not ONE netbios name. On my OK machine, I can browse all 13.
    – Mike S
    May 18, 2016 at 0:01
  • ...Do I just need to reboot?
    – Mike S
    May 18, 2016 at 0:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .