Installing any feature with the Server Manager, it hangs on "Starting Installation".

When I install the feature with PowerShell, it works fine, only when I open up Server Manager to configure the feature after the installation I get a "failed to open the runspace pool" error.

Configuring it via PowerShell works fine. Then, when I tried to configure DirectAccess with its Quick Start wizard, it gives me a "could not connect to the destination specified in the request" error.

Running "winrm quickconfig" produces this:

WinRM service is already running on this machine. WinRM is already set up for remote management on this computer.

This error appears in event viewer when configuring Direct access DirectAccess in Server Manager:

WSMan operation CreateShell failed, error code 2150858770

The output of winrm get winrm/config:

winrm get winrm/config
    MaxEnvelopeSizekb = 500
    MaxTimeoutms = 60000
    MaxBatchItems = 32000
    MaxProviderRequests = 4294967295
        NetworkDelayms = 5000
        URLPrefix = wsman
        AllowUnencrypted = false
            Basic = true
            Digest = true
            Kerberos = true
            Negotiate = true
            Certificate = true
            CredSSP = false
            HTTP = 5985
            HTTPS = 5986
        TrustedHosts = fs.towerdevs.xyz
        RootSDDL = O:NSG:BAD:P(A;;GA;;;BA)(A;;GR;;;IU)S:P(AU;FA;GA;;;WD)(AU;SA;GXGW;;;WD)
        MaxConcurrentOperations = 4294967295
        MaxConcurrentOperationsPerUser = 1500
        EnumerationTimeoutms = 240000
        MaxConnections = 300
        MaxPacketRetrievalTimeSeconds = 120
        AllowUnencrypted = false
            Basic = false
            Kerberos = true
            Negotiate = true
            Certificate = false
            CredSSP = true
            CbtHardeningLevel = Relaxed
            HTTP = 5985
            HTTPS = 5986
        IPv4Filter = *
        IPv6Filter = *
        EnableCompatibilityHttpListener = false
        EnableCompatibilityHttpsListener = false
        CertificateThumbprint = 80 aa c1 69 11 9d 87 b8  d8 7a 20 b8 ff 76 d2 3ddb dc 7b 7f
        AllowRemoteAccess = true
        AllowRemoteShellAccess = true [Source="GPO"]
        IdleTimeout = 7200000
        MaxConcurrentUsers = 10
        MaxShellRunTime = 2147483647
        MaxProcessesPerShell = 25
        MaxMemoryPerShellMB = 1024
        MaxShellsPerUser = 30

And winrm enumerate winrm/config/listener:

PS C:\Windows\System32\WindowsPowerShell\v1.0> winrm enumerate winrm/config/listener
    Address = *
    Transport = HTTP
    Port = 5985
    Enabled = true
    URLPrefix = wsman
    ListeningOn =,,,, ::1, fe80::5efe:, fe80::5
efe:, fe80::d13:6e93:f4dd:e045%12, fe80::84a1:52c5:715:a4e5%15, fe80::fdb7:1050:858e:9139%14

    Address = *
    Transport = HTTPS
    Port = 5986
    Hostname = fs.towerdevs.xyz
    Enabled = true
    URLPrefix = wsman
    CertificateThumbprint = 80 aa c1 69 11 9d 87 b8  d8 7a 20 b8 ff 76 d2 3ddb dc 7b 7f
    ListeningOn =,,,, ::1, fe80::5efe:, fe80::5
efe:, fe80::d13:6e93:f4dd:e045%12, fe80::84a1:52c5:715:a4e5%15, fe80::fdb7:1050:858e:9139%14`

The server runs these roles/features:


AD CS (Certification Authority)

AD DS (Domain Controller)

DNS Server

File and Storages Server (File Server & Storage Services)


Remote Access (DirectAccess and VPN)

Web Server (IIS)

Windows Deployment Services


.NET Framework 3.5

.NET Framework 4.5

Bitlocker and Network Unlock

Enhanced Storage

Group Policy Management

Ink & Handwriting Services

Media Foundation




User Interfaces and Infrastructure

Windows Internal Database

Windows PowerShell


Wireless LAN Service

Wow64 Support

  • We had a switch that failed, someone rebooted it, and at that point it had already flipped over to a separate highly available machine. Thus there were two copies of that machine on the network and when you started communicating with one of them, the other would say there wasn't a session open.
    – leeand00
    Commented Feb 15, 2021 at 16:30

1 Answer 1


I solved a similar WinRM error using Hyper-V Manager console to a remote virtualization host, an access denied error resulting in 2150858770. Dig into the host server's "Windows Remote Management" event log to find the evidence. Then follow the steps in this blog to configure the server: 1,

  • Open firewall for "Windows Management Instrumentation"
  • dcomcnfg to enable remote launch and remote activation
  • In Computer Management, Services and Applications\WMI Control; right-click Proerties> turn on 'remote enable' for namespace and
    sub-namespaces for the current container (Note: the Win 10 UI has
    changed from those in the blog - just click advanced and hunt for the right settings).

    You must log in to answer this question.

    Not the answer you're looking for? Browse other questions tagged .