0

Since this morning, I'm unable to RDP into my new and old Windows EC2 instances. Below are the things I have tried already:

  1. I've tried creating instances using:

    a. Windows Server 2012 R2 Base

    b. Windows Server 2008 R2 Base

  2. I've also checked the security group associated with the instance and confirmed that it contains an input rule for RDP from Anywhere.

  3. I've double/triple checked the IP address, Username, and the Default Password.
  4. I've also checked the routing table for the subnet so that it contains the route from 0.0.0.0/0 to the internet gateway.

Even after all this, I'm unable to RDP into the instance. I get the following error after the message "Initiating remote connection":

Remote Desktop can't connect to the remote computer for one of these reasons:

1) Remote access to the server is not enabled

2) The remote computer is turned off

3) The remote computer is not available on the network

Make sure the remote computer is turned on and connected to the network, and that remote access is enabled

Any suggestions, please?

  • How about telling us what happens or what messages you get when you try? – joeqwerty May 9 '16 at 12:13
  • added the error message in the question itself. – chaudharyp May 9 '16 at 12:16
  • Is your on premise restriction any, your local Firewall ? Was it connected earlier and suddenly stops connecting ? – vembutech May 9 '16 at 12:45
  • Yes. Even i figured it out just now. Just spent 4.5 hours on nothing. :( Thanks for the help guys. – chaudharyp May 9 '16 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.