1

I'm following EliTheComputerGuy's Windows Server 2012 tutorials to setup my Windows Server and office computers with Active Directory:

https://www.youtube.com/watch?v=ZfsXh_LSkgE

I want to setup Windows Server 2012 so all devices connected to my network get an IP address within a given range (10.x.x.x). As DHCP is enabled on the router within my building's reception and I have no way of disabling it, I can't connect the Ethernet wire supplying internet directly to my switch as this will give all devices connected to it an IP addresses within the 10.11.22.x range which I don't want as I want to create my own subnet.

Here's my setup:

Windows server with 2 NIC's:

  • NIC1 = Static IP (10.11.22.50)
  • NIC2 = Static IP (10.0.0.1)

NIC1 connects to the external network using an ethernet wire coming into the building. NIC2 connects to the switch to form my private network.

I've followed the video and all is working well so far: DHCP is working FINE and the server is giving my laptop an IP of 10.0.0.20 (20 ips are reseved as per my network setup).

However, Eli only uses 1 NIC in his video but I have two in my server and have to use two to get access to the external network and my private network.

For test purposes, I've connected my laptop to NIC2 so I can test if internet is working.

The laptop gets an IP address from DHCP but no websites can be accessed from the browser. If I ping from my laptop I get the following outputs:

  • 10.0.0.1 = success
  • 10.11.22.50 = timeout
  • 10.11.22.254 = timeout

So for some reason Windows server is not letting me access the internet from external devices on my new network through the internet connection that comes to the server from NIC1.

I've already tried messing around with different routing services and disabling my firewall completely to ensure nothing is being blocked, however I'm still facing the same issue. What else can I try to get internet access working?

I appreciate this question may be slightly hard to understand, so I'm willing to provide more information (diagrams, configs, etc.) if need be.

Thanks!

1
  • This could be two main problems: no gateway set or router messing up when NATing. Does it has a route to the subnet?
    – sysfiend
    May 9, 2016 at 14:19

3 Answers 3

1

Make sure you enable the NAT on the external interface on your Routing options,only then the settings you configured in your DHCP Reservation settings will work.

1
  • This was the solution! I hired @Erick to fix this issue. Turns out it was just a matter of needing another set of eyes to look over what I'd already set up on the server and finding the dialog to enable NAT. May 11, 2016 at 17:29
1

Access to the Internet will happen after you can access the gateway, so solve that problem first. That is, you will need for DHCP hosts to be able to ping 10.11.22.50.

A priori, there are three possibilities:

  1. The DHCP host is not dropping the ICMP echo request on the wire.
  2. The transport between the DHCP host and the gateway is not happening.
  3. The gateway host is not dropping the ICMP echo reply on the [right] wire.

It sounds like you have a local switch with everything hanging off that one switch, so its unlikely to be #2, assuming that DHCP is happening correctly.

To see what is happening on the wire, "wireshark" is your friend. Install, and look at the sniffer trace. However, until you go there you can at least review routing tables.

On the DHCP host, you need to have a routing table entry to tell it where to send packets that aren't local. Look for something like

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0          10.0.0.1      10.0.0.X     10

If that isn't there, its the source of your problem. Your default gateway should be supplied by the DHCP server, so recheck that configuration.

If that isn't there, then its possible that the gateway host for some reason isn't aware of the locally attached network. (The ping to that interface is working, so its unlikely.)

I'm betting on #1.

0

A routers main functionality is IP forward. So please take a look at ip_forward settings in your router, to allow traffic flowing from internal interface to external interface.

For Linux, you can edit file /etc/sysctl.conf with the following lines:

# IP forward needed by router
net.ipv4.ip_forward=1
net.ipv6.conf.all.forwarding=1

To apply changes, type: sysctl -p

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .