0

A little about our setup and what I'm trying to do:

All machines in question running Windows 8.1 Pro

Remote machine users connect to our internal network with Cisco Systems VPN Client 5.0.07.0440 All machines on the internal network we can use RDC to remotely connect to however for whatever reason we can only remotely connect to the remote machines (who are VPN'd into the internal network) if their local network connection is set to trusted (private / home). If they are connected to a network thats set to a Public trust level we cannot use RDC to connect to them (standard error below); also cannot \0.0.0.0\c$ to those machines. It's my understanding that using the VPN should utilize the VPN's connection settings not have to abide by local network connection settings.

RDC Error

Any thoughts or assistance with this issue would be greatly appreciated.

Network Adapter Settings

  • Why do you want to RDP from your internal network to a remote computer that is connected to the internal network via VPN? – user5870571 May 11 '16 at 19:38
  • Administrative purposes. user accounts are quite locked down and remote admin access is necessary at times (preferably without giving said remote user the administrator credentials) – k.pillow May 11 '16 at 20:49
1

Even though the Cisco Client has its own virtual adapter showing in Network Connections, it is still utilizing the physical adapter to tunnel through. The physical adapter is controlled by Microsoft's somewhat less than brilliant Network Location Awareness Service. This service disregards any Windows Firewall or third party firewall rules, and allows no traffic into the interface when it thinks it is on a public network. To Change this run secpol.msc from the run command. Go into Network List Manager Policies and change Unidentified Networks from public to private, as well as Identifying Networks from public to private. Select user can change location to make the location in Network and Sharing Center clickable. Disable and re-enable the physical adapter in Network Connections, and select work for the network location.

  • The problem with defaulting networks to a Private trust is that remote users may not always be in a secure environment when they connect to the vpn. With a public network (such as a starbucks) being trusted like that it opens the machine up as a security threat. – k.pillow May 11 '16 at 16:55
0

Basically, Windows does not know about the VPNs IP address at all. The Cisco VPN client does some magic with how the packets are routed, but there is no separate network interface for that tunnel. So to Windows it seems like all traffic comes from its only interface with that public IP, regardless of VPN on or off.

Potential solutions:

  • have a hardware VPNS gateway
  • use a VPN solution that creates a proper tunnel interface.
  • I added an image to my initial question showing the 2 separate adapter settings (one for the vpn and one for the wireless connection). Its my understanding that this is a separate network interface and when accessing internal services I see traffic (bytes sent / received) on the VPN adapter but not on the Wireless one, is it not already using a tunnel? – k.pillow May 11 '16 at 15:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.