We have Domain Controllers where our internal DNS runs on. 2 Windows 2008R2 and 2 Windows 2012R2.

Our stale records are no longer removed for some time now, even when running the DnsCmd commands manually or through the GUI.

It seems to happen since we set dynamic updates to secure. It happens for all AD-integrated zones and normal zones including reverse lookup zones.

Things I've tried:




2 Answers 2


For the zone in question run the following command:

dnscmd /zoneinfo foobar.com

You will get the result like this:

Zone query result:
Zone info:
            ptr                   = 0000000000327C90
            zone name             = foobar.com

            zone DN = DC=fopobar.com,cn=MicrosoftDNS,DC=DomainDnsZones,DC=foobar,DC=com          Scavenge Servers
           Server[0] => af=2, salen=16, [sub=0, flag=00000000] p=13568, addr=

Here you notice the IP address

This is the IP address of the only server which has the permission to scavenge the zone. Most likely this could be a server which is no longer existing - this happens a lot in Domains with a funktion level of 2008. If this is not the IP address of the server which on which you have configured Scavenging, you need to change that.

To change the Scavenging server for a zone, run the command:

dnscmd /zoneresetscavengeservers foobar.com <IP of the correct DNS Server>

And a few moments later, your DNS is working with Scavenging again.

  • Looks like it wasn't set on the server Properties ... facepalm. Have set it now and will evaluate.
    – aairey
    May 27, 2016 at 14:20
  • Ok it is working. I've added multiple servers as "ScavengerServer".
    – aairey
    May 27, 2016 at 14:21

Have you made any changes to the expiry interval? Did you set DHCP option 81?

Maybe this guide can be helpfull: http://blogs.msmvps.com/acefekay/2009/08/20/dhcp-dynamic-dns-updates-scavenging-static-entries-amp-timestamps-and-the-dnsproxyupdate-group/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .