0

Issue arose when an attachment froze at the send stage (after uploading fine) in mutt 1.5.24. I updated to mutt 1.6.1, same compile flags, but still didn't send. Tested in Thunderbird (icedove) and it did send, with the same settings. I have sent hundreds, if not thousands of attachments over the last year or so this way and have changed nothing of the settings. The freezing has happened once or twice but I thought it was down to the recipient. Now it's happening on every attachment to any address. I do have Gmail settings configured in Mutt, and when I send an attachment using those, it works fine.

The mail server is on a VPS, using Postfix and Dovecot. The debug log for the sending email address is below, at least the relevant part where it times out after waiting for a long time. The attachment size limit is over 50MB. I'll post my postconf -n below also.

I have posted other details regarding MTU etc. here.

Mutt sometimes reports: smtp session failed: write error

So my main question is, why this sudden change in behaviour? What could cause mail with attachments to not send via Mutt (both 1.5.24 and 1.6.1), but to send via Thunderbird, and for all mails without attachments to send just fine?


Postfix debug log

May 12 13:18:40 mail postfix/smtps/smtpd[26433]: smtp_get: timeout
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: > [ip]: 421 4.4.2 mail.sendingdomain.com Error: timeout exceeded
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: match_hostname: [ip] ~? 127.0.0.0/8
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: match_hostaddr: [ip] ~? 127.0.0.0/8
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: match_hostname: [ip] ~? [::ffff:127.0.0.0]/104
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: match_hostaddr: [ip] ~? [::ffff:127.0.0.0]/104
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: match_hostname: [ip] ~? [::1]/128
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: match_hostaddr: [ip] ~? [::1]/128
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: match_list_match: [ip]: no match
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: match_list_match: [ip]: no match
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: send attr request = disconnect
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: send attr ident = smtps:[ip]
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: private/anvil: wanted attribute: status
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: input attribute name: status
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: input attribute value: 0
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: private/anvil: wanted attribute: (list terminator)
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: input attribute name: (end)
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: timeout after DATA (172469 bytes) from [ip]
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: abort all milters
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: milter8_abort: abort milter inet:localhost:12301
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: abort all milters
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: milter8_abort: abort milter inet:localhost:12301
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: disconnect event to all milters
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: milter8_disc_event: quit milter inet:localhost:12301
May 12 13:18:40 mail postfix/smtps/smtpd[26433]: disconnect from [ip]

Postconf -n

EDIT: postconf -n readout removed due to irrelevance, solution found
0

To save anyone else time in the future. rob0 of the #postfix channel on freenode suggested (yesterday) that smtps (showing in my logs) was not in the standard. Only today I realised that my mutt config includes smtps:// for the set smtp_url setting per account. Only the Gmail one didn't. And that was the one that was working.

Why it stopped all of a sudden, I'm not sure. A VPS firewall update, perhaps, I really don't know.

HTH

EDIT: The VPS provider and the ISP both say that smtps is not something they would block. So unless I'm blocking myself somewhere, with a new setting that perhaps an update brought into play, I'm at a loss to explain how it happened. If anyone ever finds out more, please leave a comment!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.