27

I am trying to install Windows 7 on Proxmox Virtual Environment version 4.2-4/2660193c, running on Debian Jessie. I have followed the instructions on this site.

I uploaded a known-good Win7 ISO (that works fine with VirtualBox and real hardware) to Proxmox, and configured VM following the recommended best practices.

When the VM is started, Windows shows the gray text mode progress bar saying "Windows is loading files ...", then switches to "Starting Windows" and stays there for hours.

There is no visible action, no colored Windows logo, no animation, no disk I/O, no CPU load, no log output. No way to continue.

XP Home installed without any problems in a VM.

Host is Intel Core i5, VT enabled, 32 GByte RAM, 8 TByte SATA disks.

How do I get Win7 to continue its setup process on Proxmox 4.2?

3
  • Is this what passes as a question in your estimation. It looks like a statement to me. What are we to make of this? – joeqwerty May 12 '16 at 15:24
  • is the VM configured to use UEFI or BIOS/legacy mode? – magicandre1981 May 13 '16 at 14:21
  • VM is configured largely to defaults, "BIOS" Option is set to "Default (SeaBIOS)". Solution was to switch to "cirrus" VGA. – Alexander Foken May 14 '16 at 6:58
40

It's a (known) bug.

Workaround: Change the display from 'default' to 'cirrus'. You can find this setting under hardware > display.

Or, if you are creating the VM on the command line using virt-install, just add --video cirrus. For example:

sudo virt-install \ --virt-type=kvm \ --name windows7 \ --ram 2048 \ --vcpus=2 \ --os-variant=win7 \ --virt-type=kvm \ --hvm \ --cdrom=/var/lib/libvirt/boot/windows7.iso \ --network=bridge=virbr0,model=virtio \ --graphics vnc \ --disk path=/var/lib/libvirt/images/windows7.qcow2,size=256,sparse=yes,bus=virtio,format=qcow2 \ --video cirrus

9
  • Yes, confirmed by a proxmox staff member at their forums, changing to "cirrus" helps. – Alexander Foken May 14 '16 at 6:49
  • Same bug appears to be in Debian Jessie (v8.4) itself. – Michal Sokolowski May 15 '16 at 18:12
  • 4
    Same bug affects Ubuntu 16.04. – James Johnston May 23 '16 at 14:14
  • 1
    Confirmed the issue and fix in ArchLinux. I suspect it is a "missing driver"-type issue with the Win7 iso rather than a bug with qemu. – zaTricky Jul 7 '16 at 18:26
  • The same solution here with CentOS 7.2.1511 libvirt 1.2.17 and qemu-kvm 1.5.3 – St. Hermes Sep 16 '16 at 11:23
1

The solution is to switch to "cirrus" on VGA options. That work for me.

0

On the final part (5/5) of the 'Create a new virtual machine' wizard, click the 'Customise configuration before install' checkbox and proceed, then you will get some more options. Choose the 'Video QXL' option and use the Model dropdown to select 'Cirrus' and that will do the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.