0

I have copied a Datadisk from Standard Storage to a newly created Premium storage container.

However, when running

$azure vm disk show myPremiumDatadisk 

The results return: "isPremium false" , (as well as the performance has not improved.)

I have also tried to upload a vhd directly from my computer and register the disk in the premium account, so that is has not touched the standard storage, and the same thing happens..

How can I convert an existing datadisk to Premium?

I have followed this documentation to no avail:

https://azure.microsoft.com/en-us/documentation/articles/storage-premium-storage/

and

https://azure.microsoft.com/en-us/documentation/articles/storage-migration-to-premium-storage/

Thanks.

migrated from stackoverflow.com May 12 '16 at 21:28

This question came from our site for professional and enthusiast programmers.

  • Did you recreate the VM with the new disk / re-add the premium disk? Can you confirm this by checking the URI on the disk to ensure it is the premium account? What is the size of the standard disk? – CtrlDot May 9 '16 at 3:48
  • Yes thanks - I recreated the VM using the OS disk that I also copied, and then attached (and registered) the copied datadisk. The VM is Standard DS2, the Storage container is Premium-LRS, the size of the datadisk is 30GB , and the size of the OS (Linux Centos 6.6) is 52GB .. and the URI is the premium storage. – leo_oz May 9 '16 at 3:56
  • P.S - The VM is a classic VM not an ARM VM - could this play a part? – leo_oz May 9 '16 at 4:06
  • Nope, the 30GB disk is probably a P10. That will only be 500 iops, same as standard. Throughput is based on disk size. What disk allocations do you have set? Read/write caching? – CtrlDot May 9 '16 at 4:39
  • Thanks CtrlDot - What do you mean by disk allocations? As far as I understand, even if using 500 iops limited by the P10 disk, the storage should still be Premium, and with Premium that is a guarenteed 500 iops, vs the standard which is 'possible' iops, and Azure recommends that only for dev / test purposes.. Still not sure how to get the disk to display as premium – leo_oz May 9 '16 at 6:50
0

Turns out this is a "bug" in the Azure side - the cli will incorrectly report "isPremium = false", but the storage is in fact isPremium. This is registered here at this github: https://github.com/Azure/azure-xplat-cli/issues/2591

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.