0

I'm trying to setup websvn on Raspberry Pi using apache. In /etc/apache2/conf.d/websvn I have the following configuration:

# Configuration for websvn using php4.

Alias /websvn /usr/share/websvn

<Directory /usr/share/websvn>
  ## No MultiViews
  DirectoryIndex index.php
  Options FollowSymLinks
  ## MultiViews
  #DirectoryIndex wsvn.php
  #Options FollowSymLinks MultiViews
  ## End MultiViews
  Order allow,deny
  Allow from all
  <IfModule mod_php4.c>
    php_flag magic_quotes_gpc Off
    php_flag track_vars On
  </IfModule>
</Directory>

But when I try to connect to http://.../websvn I get the error 404. In the apache log I read (I had to bump the log level):

[Sat May 14 12:17:52.737294 2016] [authz_core:debug] [pid 652] mod_authz_core.c(809): [client 79.54.45.40:51893] AH01626: authorization result of Require all granted: granted
[Sat May 14 12:17:52.738726 2016] [authz_core:debug] [pid 652] mod_authz_core.c(809): [client 79.54.45.40:51893] AH01626: authorization result of <RequireAny>: granted
[Sat May 14 12:17:52.741081 2016] [core:info] [pid 652] [client 79.54.45.40:51893] AH00128: File does not exist: /var/www/html/websvn

So I suppose the problem is that it is trying to route to /var/www/html/websvn, which does not exist at all. Instead I suppose it should read from /usr/share/websvn, like that alias. Any idea why this may be happening? I grepped the entire /etc directory and I found no occurrence of the string "/var/www/html/websvn".

0

Problem was related to the fact that websvn conf file was placed in /etc/apache2/conf.d instead of /etc/apache2/modules-enabled. Just symlinking from modules-enabled fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.