2

I have set up a server based on windows server 2008 R2, and has successfully joined 2 clients (one PC and one laptop, both windows 7) to the domain.

Today I was trying to join another laptop to the domain. It has windows 8.1 on it. It recognized the domain name well, and asked for username and password. But it couldn't join, and give the following error:

The following error occurred attempting to join the domain.

The specified domain either does not exist or could not be contacted.

enter image description here


On other clients before, I had set the preferred DNS server to 192.168.1.33. and they had successfully joined the domain. (They were all windows 7)

In the new client laptop (windows 8.1), under network and sharing center, the properties of IPv4, I set the preferred DNS server to 192.168.1.33 but it didn't work. Then changed it to 127.0.0.1 but again it didn't work.

The similar topics (like "The specified domain either does not exist or could not be contacted" when joining a computer the domain) suggest to check DNS, but don't give a clear solution. They say the number 1 rule is to check DNS. OK, sure; But, How should I do this?

How can I solve this problem!!?

Your time and help is highly appreciated.


P.S. 1

The following is the result of ipconfig/all run from server PC:

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Administrator>ipconfig/all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : SAPNA
   Primary Dns Suffix  . . . . . . . : SAPNA.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : SAPNA.local

Ethernet adapter Local Area Connection* 9:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Anchorfree HSS VPN Adapter
   Physical Address. . . . . . . . . : 00-FF-7D-96-A7-FE
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek RTL8168C(P)/8111C(P) Family PCI-E
 Gigabit Ethernet NIC (NDIS 6.20)
   Physical Address. . . . . . . . . : 00-1F-D0-D1-58-A3
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::345d:4bf0:d080:a8ac%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.33(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Sunday, May 15, 2016 1:37:22 PM
   Lease Expires . . . . . . . . . . : Monday, May 16, 2016 1:37:22 AM
   Default Gateway . . . . . . . . . : fe80::1%12
                                       192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 251666384
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-BD-1C-4D-00-1F-D0-D1-58-A3

   DNS Servers . . . . . . . . . . . : ::1
                                       127.0.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter VMware Network Adapter VMnet1:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
1
   Physical Address. . . . . . . . . : 00-50-56-C0-00-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::4507:6e27:a2:1b65%16(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.153.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 419450966
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-BD-1C-4D-00-1F-D0-D1-58-A3

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter VMware Network Adapter VMnet8:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet
8
   Physical Address. . . . . . . . . : 00-50-56-C0-00-08
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::d04c:7fcb:8586:aac0%18(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.40.1(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 453005398
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1E-BD-1C-4D-00-1F-D0-D1-58-A3

   DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
                                       fec0:0:0:ffff::2%1
                                       fec0:0:0:ffff::3%1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{76D09E79-629B-4FB9-A0DA-FA7FBB337287}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 11:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{F8119BC6-91C4-480A-AE3F-D26B3C21038E}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{7D96A7FE-A04E-43BB-8A17-C0F583BD8A07}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{59DA0B44-2E23-442B-89AD-C39945CA10C9}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

C:\Users\Administrator>

Edit 1

These are the nslookup results:

The Server PC trying to look up one of the client PCs:

C:\Users\Administrator>nslookup PC-SH
Server:  localhost
Address:  ::1 

Name:    PC-SH.SAPNA.local
Address:  192.168.1.37

The server PC trying to look up itself:

C:\Users\Administrator>nslookup SAPNA
Server:  localhost
Address:  ::1

Name:    SAPNA.SAPNA.local
Addresses:  192.168.40.1
          192.168.153.1
          192.168.1.33

Edit 2

The nslookup command running on a wireless laptop which has successfully joined the domain, results in DNS Request Timed Out, no matter what to look up, whether itself, the server, or other PCs!

Edit 3

It seems that the problem is with the windows-8.1 laptop. Because I just added another wireless laptop with windows 7 to the domain successfully.

11
  • 1
    Why are you running VMware Workstation/Player on your Domain Controller? Get rid of that. – joeqwerty May 15 '16 at 16:51
  • Do a nslookup on the win8.1 client. I suspect it is not getting the search domain. In which case, check your DNS settings. – AWippler May 16 '16 at 3:02
  • @joeqwerty, I'm using VMware workstation, because I often need linux ubuntu on this machine. I don't think this might be the problem; right? Because I have successfully joined 3 PCs and laptops to the domain. – Omid1989 May 16 '16 at 3:09
  • @AWippler, Thanks for your comment. But what do you exactly mean with check your DNS settings !? Where should I check it? How should it be to be correct? – Omid1989 May 16 '16 at 3:10
  • You would check it on the client. Make sure it can get to the AD via hostname, NetBIOS name, and IP. – AWippler May 16 '16 at 3:11
1

EDIT: Made it more Human readable

  1. How a domain controller works
  2. Configure the client to use the Domain controller DNS service.

How a domain controller works

When you configuring a domain controller there will be also an DNS service installed. Without this service your domain is not reachable. On the domain controller set the Primary DNS (by default) to 127.0.0.1 and the secondary EMPTY or if you have a second controller put the second controller IP in.

do not 8.8.8.8 or an other external dns in there this will not work and breaks your domain

When you are done with that you can configure your client

Configure the client to use the Domain controller DNS service.

When you are configuring an static IP on the PC put on the primary DNS the IP of the domaincontroller, and leave the secondary empty( or if required fill the IP of the second domain controller in there).

Configure the Interface static like so:

IP: 192.168.1.33

Subnet mask 255.255.255.0

Default gateway 192.168.1.1

Primary DNS 192.168.1.37

Secondary EMPTY or secondary domain controller if required

Same rule dont put any external DNS service in the second one this may break your domain services

I hop ethis will help you if not let me know then i will try to help you out :)

3
  • Thanks @Andrius for your answer. But I didn't understand much about what you said! Would you please add clear step-by-step guide on what shall I do ? For example, the first step you say *Dns as localhost is not working on the machine you want to join the domain, set that to your domain controller. * what dies this mean? – Omid1989 May 15 '16 at 11:20
  • Please see Edit 1 on main topic. – Omid1989 May 15 '16 at 13:03
  • @Omid1989 I`ve changed my solution, i hope this will help you out. And sorry for the delayed response I had some thing to take care off :) – Andrius May 24 '16 at 6:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.